Jump to content
BTM_Pix

Would You Perhaps Be Interested In A Different GX80/85 Colour Profile???

Recommended Posts

1 hour ago, Aeolian said:

Oh my god, this hack has been on my wishlist for a long time. Now my old G6 finally became a NTSC one and I will spend the rest of the day with a bottle of beer on my patio 😉

thanks

Where is the patio located?

Share this post


Link to post
Share on other sites
EOSHD Pro Color for Sony cameras EOSHD Pro LOG for Sony CamerasEOSHD C-LOG and Film Profiles for All Canon DSLRs

What a amazing find!! I'm using cinelike d on my g7 but now more than ever i want an gx85 or gx80. Finally the "cheap" panas with 5 axis got good colors!

Is this the only thing that we can expect from this hack? I mean... can we hope for higher bitrates, anamorphic modes and other gh4 features? 

Thanks!! 

Share this post


Link to post
Share on other sites
On 5/31/2017 at 4:46 AM, kidzrevil said:

This IS cinelike d. It has been graded to taste. I get way better results exposing to 90 ire thats my point and you can see the same thing in the panasonic white paper and how cine d handles highlights

Whoops sorry 

I'm not an expert in LOG, but I would like to mention that with my G7 cams ETTR+CineD works fine for me in my studio, but I get weird and even unusable results under bright spotlights (like theatre or concert lighting). I've had blown highlights with weird colors even with zero zebras on screen. And using multiple cams I get the same weird results sometimes. So it could be that there is a condition in which ETTR is fooled by the camera somehow, depending on both the lights and the subject material. However, in the studio under controlled lighting I get a bit more DR with ETTR (tested with Leeming LUT and my own LUTS).

53 minutes ago, jonpais said:

BTM could answer better than I can, since I haven't hacked anything in my life. My only experience was with the GH4, where I saved Vlog in one of the custom settings, and I experienced the same thing you're experiencing. Whenever the camera went to sleep, I had to reset white balance and aperture all over again.

At least you were smart enough to reset it, I just happily filmed away........

Share this post


Link to post
Share on other sites
4 minutes ago, QB3 said:

I'm not an expert in LOG, but I would like to mention that with my G7 cams ETTR+CineD works fine for me in my studio, but I get weird and even unusable results under bright spotlights (like theatre or concert lighting). I've had blown highlights with weird colors even with zero zebras on screen. And using multiple cams I get the same weird results sometimes. So it could be that there is a condition in which ETTR is fooled by the camera somehow, depending on both the lights and the subject material. However, in the studio under controlled lighting I get a bit more DR with ETTR (tested with Leeming LUT and my own LUTS).

At least you were smart enough to reset it, I just happily filmed away........

Not really, I made the same mistake as you in the beginning. :) 

Share this post


Link to post
Share on other sites
15 minutes ago, samuel.cabral said:

What a amazing find!! I'm using cinelike d on my g7 but now more than ever i want an gx85 or gx80. Finally the "cheap" panas with 5 axis got good colors!

Is this the only thing that we can expect from this hack? I mean... can we hope for higher bitrates, anamorphic modes and other gh4 features? 

Thanks!! 

It's my understanding that this is really the apex find with this workaround... which in and of itself is really spectacular and BTM should be commended for figuring this out. If there is anything more to be had, now that's just gravy.

I believe he has offered the materials for others to test certain things but doesn't believe the higher bitrates, V Log, etc... is possible. 

Share this post


Link to post
Share on other sites
5 hours ago, BTM_Pix said:

Depending on your Android phone, some of them have a pop up warning when whatver its connected to via WiFi (the camera in this case) doesn't have an Internet connection. It then drops that connection (usually for something in range that does have internet) if you don't confirm quite quickly that it's OK. The pop up sometimes doesnt get to the front of the screen though depending on whats happening on other running apps.

Might be that but might not but no there is no fundamental difference why it wouldn't work on a phone. Unless you've got the Panasonic App open at the same time which will stop a simultaneous browser connection.

I think that is what happening when using blue tooth to initiate the wifi connection. which is annoying. 

Share this post


Link to post
Share on other sites

So, as I've stated a few times already, this find is awesome and makes me wish I didn't sell the GX85. I miss me some 5-axis. So much so, I've been looking to put together a simple one lens set up, really just for family stuff and for taking the camera into the city and other places I don't really want or need to bring my 5D3.

 I am really impressed by the organic look and rock steady IBIS from Olympus. If you haven't used one, there is a Night and Day difference between their incarnation and Panasonic's but for a whole lot cheaper, I can't complain about Panasonic's variant.

So this leads me to ask... is the 5-axis better with the heavier body of the G85? I remember they had some issues with IBIS in the beginning but I believe it's been resolved and I believe it was lens specific. Since I would only use it with a manual lens, I doubt it's relevant.

Also does anyone use the G85 with the battery grip and does that help settle the floaty Panasonic IBIS?

With this "hack" the GX85 is the cheaper price, but the G85 offers a bit more for not much more so it's probably worth it to me if the IBIS is more solid on the G85.

Also has anyone tested the hack with GX850? That camera doesn't have the IBIS, but it would be a great tripod cam for a two camera shoot with either the GX85 or G85 going handheld.

Share this post


Link to post
Share on other sites

@mercer I use the g85 with the battery grip and its a dream ! I love how panasonic also allows you to use the touch screen to move the manual focus assist while you are looking through the viewfinder. The grip + IBIS + touch screen = a dream

Share this post


Link to post
Share on other sites
4 minutes ago, kidzrevil said:

@mercer I use the g85 with the battery grip and its a dream ! I love how panasonic also allows you to use the touch screen to move the manual focus assist while you are looking through the viewfinder. The grip + IBIS + touch screen = a dream

I've been really impressed with your results, but I think you have a steadier hand than I have. I actually don't mind the "floaty" look... actually I quite like it, but with the Olympus, you can walk with it... it's pretty insane. Have you tested the G85's IBIS with and without the grip and if so, did you notice any difference?

Share this post


Link to post
Share on other sites
2 hours ago, mercer said:

It's my understanding that this is really the apex find with this workaround... which in and of itself is really spectacular and BTM should be commended for figuring this out. If there is anything more to be had, now that's just gravy.

I believe he has offered the materials for others to test certain things but doesn't believe the higher bitrates, V Log, etc... is possible. 

Yes.

There is definitely more to comes in terms of applying the processes to enhance the usability of all of the small Panasonic cameras that can be app controlled (which is where I originally came in with this!) than in unlocking additional rates and so on.

What I would like to spend a bit of additional time on though is trying to get it working on the LX100. I think there is something in there with that and it would be very useful on that camera. Ditto the travel cameras.

With regard to the bitrate stuff, I'll knock something up that will make it easy to do a matrix test as I think the behaviour changes when switching to the usually non-supported ones depending on which one you are currently set to. So there might be a combination that works.

Vlog? Mmm....I think I'm pretty confident that it won't work. I believe after looking at some logs I've received that I'm sending it the correct command but its no go.

Though as you say, hopefully everyone has the tools they need to poke around with this themselves now on different cameras so maybe someone can find the solution themselves.

 

Share this post


Link to post
Share on other sites
1 hour ago, mercer said:

I've been really impressed with your results, but I think you have a steadier hand than I have. I actually don't mind the "floaty" look... actually I quite like it, but with the Olympus, you can walk with it... it's pretty insane. Have you tested the G85's IBIS with and without the grip and if so, did you notice any difference?

nah I haven't tested without the grip ! its harder for me to shoot handheld without battery grip :-(

Share this post


Link to post
Share on other sites
6 hours ago, QB3 said:

Going to try this out today. Thanks for all the work! A question: I had a bad experience with my G7 using CineD where the camera went into sleep mode or maybe was turned off while I was on C1 or C2, etc. When it woke up, some of the WB balance settings had changed and we shot a whole sequence in orange, basically. Does anyone know under what conditions this happens and how to avoid it? Is it the same for the GX85 when using this hack? Tx.

Its part of the feature as far as Panasonic are concerned so you can get quickly back to a known setting including white balance. A lot of people would use it specifically for that to be honest, maybe have a higher ISO and tungsten balance for indoors and then quickly revert to a lower ISO and a daylight balance when they go outdoors. 

Fuji handle it slightly differently in that you have your C settings but with a different 'active' one for want of a better description if you made any changes which persists when you turn the camera off whereas Panasonic always recalls it exactly from the C setting even when you turn the mode dial and come back. 

What I recommend for GX80 to make the Cinelike D/V in camera switchable is to save it to C1 with a jumping off point of ISO and WB and so on and do the same with a standard profile to C2. And then use C3 to save the changes you've made to whichever of those basic profiles you're currently working on so they persist when the camera is switched off.

So it would be like this :

1) Save Cinelike D with 1/50th, AWB, ISO200, 4k24p into C1

2) Save Standard with 1/50th, AWB, ISO200, 4k24p into C2

3) Start camera and choose C1 or C2

4) Make changes to your WB, ISO and file format that you need for this specific session.

5) Save to C3

Now when you switch the camera off it will come back with the settings of C3 (i.e. your currently edited version of your primary profile) and will also do so when you change modes.

You can use exactly this same approach on your G7 to enjoy the benefits of the Custom settings but preventing that WB issue happening again.

Share this post


Link to post
Share on other sites

I have tried to get some higher rate video modes on the GX80 ("mp4ed") and although the camera does respond with the OK message that they are set it defaults to the standard 24p 4K as @BTM_Pix had said earlier.  If others want to try and dig around some more I have included my HTML file I have been using that has all the MP4 movie options as a drop down list for GX80 NTSC,

I'll keep hunting in the meantime :)

 

GX80-Wifi-Control.html

Share this post


Link to post
Share on other sites
24 minutes ago, robbino said:

I have tried to get some higher rate video modes on the GX80 ("mp4ed") and although the camera does respond with the OK message that they are set it defaults to the standard 24p 4K as @BTM_Pix had said earlier.  If others want to try and dig around some more I have included my HTML file I have been using that has all the MP4 movie options as a drop down list for GX80 NTSC,

I'll keep hunting in the meantime :)

 

GX80-Wifi-Control.html

I made a similar combiantions page with higher bitrates, take a look:

 

DEPLOY VIDEO QUALITY.html

Share this post


Link to post
Share on other sites

It is possible to record in high bitrate mode with this hack on the G80.
A user posted a high bitrate file he had recorded with this setting. Unfortunately, it did not open in any of the usual players.

This is not surprising, since players usually choke at such high bitrates, ref the GH5 forum.

I thought it was perhaps missing a header, but it turns out that even though normal file information software is unable to read it, there IS a header there:
And as you can see, it says that this is a video file type, Panasonic Moov, lmvhd, G-80, avchd, etc. I therefore assume this is a valid avchd header.

The file says it's recorded on a DMC-G80 ver. 1.2 on the 1st of june 2017 at 15:03:06 and he was using the Leica DG 12-60 f2.8-4.0 lens and No accessories. :-) So yes, the file is valid.

Screen Shot 2017-06-04 at 21.42.09.png

Share this post


Link to post
Share on other sites
9 hours ago, Sportin said:

Created an account just to thank @BTM_Pix for this incredible digging!! 

 

I own a Panasonic G7 and I really feel a bit afraid of pushing the color grading a bit too far since it only records 28mbs, in which case I need to bring out my nx1 which means carrying another camera. 

IMO I think the increase on the bitrate is more important than trying to nudge vlog. That's just my opinion! 

 

Do you think it's doable to perhaps have a FHD @72mbs on the g7? 

 

Thanks for all the digging again! 

Increasing the FHD up to 100mbps would be just AMAZING! :)

Share this post


Link to post
Share on other sites
13 minutes ago, robbino said:

Have you tried all the non-standard options?

What do you reffer as non standard?

I tried all my form, all your form, and many many combination that i can´t remember. (i´m on G80, not Gx80)

But as i read, G80 answers are identical and react the same way.

I  get to work as non-standar mov_25p_150mbps and mov_25p_200mbps , and even with the camera working as expected (blank info, etc) my files in this mode are corrupted.

 

Share this post


Link to post
Share on other sites
2 minutes ago, Grimor said:

What do you reffer as non standard?

I tried all my form, all your form, and many many combination that i can´t remember. (i´m on G80, not Gx80)

But as i read, G80 answers are identical and react the same way.

I I get to work as non-standar mov_25p_150mbps and mov_25p_200mbps , and even with the camera working as expected (blank info, etc) my files in this mode are corrupted.

 

I meant the bitrates that are not the standard ones on your camera.  I'll have a play with the mov settings tomorrow, thanks :)

Share this post


Link to post
Share on other sites

This have to be a team work if we want any succes.

G80 goes up to 100mbps on 4K modes, thats the reason i haven't tried anything under 100.

Don't know why .mov is the only video quality request accepted if my camera doesn't have any .mov mode.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...