Jump to content
BTM_Pix

Would You Perhaps Be Interested In A Different GX80/85 Colour Profile???

Recommended Posts

It seems like it has every command for every camera. I saw the 200mbps mov options in there. I assume there is some piece of code which communicates which camera the app is communicating with? I wonder if there is a way to trick it if the code could be singled out? I assume a GH4 would be needed to figure out that one line of code... plus a whole lot of time. Pretty cool stuff. Good job @BTM_Pix !!!

Share this post


Link to post
Share on other sites
EOSHD Pro Color for Sony cameras EOSHD Pro LOG for Sony Cameras
4 minutes ago, mercer said:

It seems like it has every command for every camera. I saw the 200mbps mov options in there. I assume there is some piece of code which communicates which camera the app is communicating with? I wonder if there is a way to trick it if the code could be singled out? I assume a GH4 would be needed to figure out that one line of code... plus a whole lot of time. Pretty cool stuff. Good job @BTM_Pix !!!

on the first part says: <menuinfo version="2.0" model="G80">

So 200mbps C24 is somewhere a hiden part of the firmware? and vlog? Must we have some hopes, @BTM_Pix ?

English is not my languaje, sorry.

Share this post


Link to post
Share on other sites

I just tried this on my zs100 and it appears to work as well.  I can't confirm 100% but the profile appears more flat than the flat settings I was using.  I can also confirm that the latest GX85 firmware update works fine with this.  

One thing to mention, if you have your camera in C1, C2, C3 setting when you apply this, it will only apply the profile to that C setting and leave all other settings as is.

Share this post


Link to post
Share on other sites

At this moment in time I wouldn't bank on it.

The Image App supports a huge range of Panasonic cameras with varying features, hence why all of their functions are listed there.

Here is the list of supported cameras by the way http://av.jpn.support.panasonic.com/support/global/cs/soft/image_app/

The process is basically the camera tells the app "I'm a GH4843985739, populate your menus with the following stuff because I can do that..." so the app will only show you what the camera can do.

You can have an educated guess at how the commands would be formed to be sent back to the camera if it did have those features that you can't see in the menu and by logging what it sends when it does have such a camera connected, hence how I could get the Cinelike D and V working and the higher ISO as well as a couple of other bits that I haven't mentioned (Non thrilling so you're not missing much)

But if the camera doesn't like or understand the command it will reject it so its not fully predictable or even changeable.

I think the bit rate stuff would be worthwhile and there might be something there but my theory about going at it when the camera is booted up in the diagnostic region change mode didn't come to anything but I'll keep trying.

My focus is going to move on to using this stuff for a hardware gadget though but everyone else is more than welcome to keep pushing commands at their cameras with the structures I've listed as every bit of info we can all share will be worthwhile.

And there is a big clue in that sentence as to what my little gadget will be getting used for......

Share this post


Link to post
Share on other sites
23 hours ago, BTM_Pix said:

Try it again as sometimes it won't accept the handshake first time round.

It should have stored a connection in the camera called D2304.

If you go into the Setup menu in the camera, then WiFi, then WiFi Function, then Select A Destination From History you should see it.

If you can confirm that that is there, it means the camera has authorised the connection so if you try again it should work.

 

I would imagine that the firmware version would not affect the initial communication link so if that doesn't work then you could confirm that you can talk to the camera through the IOS or Android app that would be useful in terms of troubleshooting.

Perhaps I'm doing this wrong then. So I first am connecting to my smartphone via the app (Android), once connected I am going to the browser on the phone and hitting Handshake. It then does one of two things. First, it's unresponsive and loading. Second, it tells me the connection has timed out.

 

Any troubleshooting I can try?

 

Thank you for the hack, btw. Very excited to use it.

Share this post


Link to post
Share on other sites
15 minutes ago, seppling said:

Perhaps I'm doing this wrong then. So I first am connecting to my smartphone via the app (Android), once connected I am going to the browser on the phone and hitting Handshake. It then does one of two things. First, it's unresponsive and loading. Second, it tells me the connection has timed out.

 

Any troubleshooting I can try?

 

Thank you for the hack, btw. Very excited to use it.

You don't need to use the Panasonic app, its all done through your browser.

1) Turn the wifi function on on the camera

2) In your wifi settings on the phone, connect to the camera. (NB Depending on how easy it is to load html files from a file on your particular phone, it might be easier to use a computer but there's no reason it won't work with a phone browser)

3) Load the html file attached here (the original one has now been updated to have both types of Cinelike)

4) Select Handshake

5) Depending on how successful your previous attempts have been the camera will accept the connection and you hit Connect.

6) If it hasn't connected first time the camera will time out. This is perfectly OK, it is waiting sometimes for a return authorisation which it wont get as we're not using the app. If this happens, just start the process again from step 1 and it will work second time round.

7) Once its connected the camera will say under remote control, then wait for it to show a live view on the LCD screen.

8) Select which version of Cinelike that you want.

9) For all subsequent connections, you won't have to do the two step handshake, it will just be > Turn on wifi on camera, connect wifi on phone, load html page, hit Handshake, hit Connect, wait for live view and then choose which Cinelike you want or select Restore to go back to Standard setting.

 

DEPLOY CINELIKE D AND V.html

Share this post


Link to post
Share on other sites
1 hour ago, BTM_Pix said:

But if the camera doesn't like or understand the command it will reject it so its not fully predictable or even changeable.

 

First of all, THANK YOU.

Thats a great and clear explanation.

So, if its not predictable, is safe to try a luck?

Can the camera get bricked? 

Or only reject the command and nothing else?

Can this be undone without your html restore button?

Share this post


Link to post
Share on other sites
34 minutes ago, BTM_Pix said:

You don't need to use the Panasonic app, its all done through your browser.

1) Turn the wifi function on on the camera

2) In your wifi settings on the phone, connect to the camera. (NB Depending on how easy it is to load html files from a file on your particular phone, it might be easier to use a computer but there's no reason it won't work with a phone browser)

3) Load the html file attached here (the original one has now been updated to have both types of Cinelike)

4) Select Handshake

5) Depending on how successful your previous attempts have been the camera will accept the connection and you hit Connect.

6) If it hasn't connected first time the camera will time out. This is perfectly OK, it is waiting sometimes for a return authorisation which it wont get as we're not using the app. If this happens, just start the process again from step 1 and it will work second time round.

7) Once its connected the camera will say under remote control, then wait for it to show a live view on the LCD screen.

8) Select which version of Cinelike that you want.

9) For all subsequent connections, you won't have to do the two step handshake, it will just be > Turn on wifi on camera, connect wifi on phone, load html page, hit Handshake, hit Connect, wait for live view and then choose which Cinelike you want or select Restore to go back to Standard setting.

 

DEPLOY CINELIKE D AND V.html

Apologies for my ignorance, I'm assuming it's within these first few steps that I'm making a mistake. In order to connect to my phone without using the app, I select my phone from device history under function. The specific function it's using is 'Upload Images from Camera'. The camera confirms connection. I then hit Handshake, and it doesn't respond in my phone browser. It begins loading and then hangs up and eventually reaches the timed out page.

You mention turning on wifi on the camera and then connecting to the camera via my phone. I'm unaware of how to do this.

Perhaps it's my wifi connection? May have to try a different network.

 

 

Share this post


Link to post
Share on other sites
1 hour ago, Grimor said:

First of all, THANK YOU.

Thats a great and clear explanation.

So, if its not predictable, is safe to try a luck?

Can the camera get bricked? 

Or only reject the command and nothing else?

Can this be undone without your html restore button?

The unpredictable aspect is that I don't know if your other attempts when you had the app and the browser open at the same time had been successful.

The only commands that get sent to the camera are ones that the app would send to it.

The Restore function gets your picture profile back to Standard from which point you can then select your other profiles again. When you have Cinelike D enabled you can't then select these, hence why I put the option in there.

As I detailed elsewhere in the thread, you can use the custom C functions to save the camera setting in both states so you only have to do this process once.

If you are at all unsure, please do not proceed with it.

At the end of the day, I'm just some stranger on the internet so as I said at the very start of this thread its entirely at your own risk.

I've got no dog in the fight so to speak as to whether anyone does this or not as I have no financial or any other incentive.

But if you brick your camera, I'll give you £20 for it ;)

43 minutes ago, seppling said:

Apologies for my ignorance, I'm assuming it's within these first few steps that I'm making a mistake. In order to connect to my phone without using the app, I select my phone from device history under function. The specific function it's using is 'Upload Images from Camera'. The camera confirms connection. I then hit Handshake, and it doesn't respond in my phone browser. It begins loading and then hangs up and eventually reaches the timed out page.

Perhaps it's my wifi connection? May have to try a different network.

 

 

When you go to previous connections on the phone, can you just list for me what they are?

The connection is a direct one between the phone and the camera so you shouldn't be trying to connect through a router.

Share this post


Link to post
Share on other sites
6 minutes ago, BTM_Pix said:

The unpredictable aspect is that I don't know if you're other attempts when you had the app and the browser open at the same time had been successful.

The only commands that get sent to the camera are ones that the app would send to it.

The Restore function gets your picture profile back to Standard from which point you can then select your other profiles again. When you have Cinelike D enabled you can't then select these, hence why I put the option in there.

As I detailed elsewhere in the thread, you can use the custom C functions to save the camera setting in both states so you only have to do this process once.

If you are at all unsure, please do not proceed with it.

At the end of the day, I'm just some stranger on the internet so as I said at the very start of this thread its entirely at your own risk.

I've got no dog in the fight so to speak as to whether anyone does this or not as I have no financial or any other incentive.

But if you brick your camera, I'll give you £20 for it ;)

When you go to previous connections on the phone, can you just list for me what they are?

The connection is a direct one between the phone and the camera so you shouldn't be trying to connect through a router.

AH, ok - the first speedbump is figured out. I wasn't going to Wi-Fi direct connect on my phone. The two devices are now directly connected via wifi and I was able to successfully initiate the handshake. However, I'm now receiving a 404 Page Not Found error when attempting to connect. Will continue to try and establish a connection via the web browser page.

Share this post


Link to post
Share on other sites

OK, I've got a camera in front of me now, so I'll give you the exact steps

1) Press Menu button on the camera

2) Go to the Setup menu

3) Navigate to WiFi

4) Select WiFi Function

5) Select New Connection  -- (This may be where its gone wrong as you may have  been using your previous phone connection )

6) Select Remote Shooting & View

7) Camera screen will now be showing the Wifi glowing beacon thing

8) Choose the SSID ID it is showing on the camera (Should be GX80-blah blah) to connect your phone or laptop to

9) Camera will show message saying 'If you have not launched the smartphone application.....' message

10) Load the html page into the browser of your phone or laptop

11) Select 'Handshake'

12) The browser will now display 'ok,GX80-xxxxx,remote,encrypted' (the xxxxxx will be your specific GX80 ID)

13) Hit 'Back' on your browser

14) Select 'Connect'

15) The browser will now display 'OK' and the camera will display 'Under Remote Control'

16) Wait until you see the live view image on the camera LCD

17) Hit 'Back' on your browser

18) Select 'Deploy Cinelike D'

19) The browser will now display 'OK'

20) On the camera display, the picture style will not be displayed (top left next to the Mode indicator)

21) To restore Standard profiles, hit 'Back' on your browser and select 'Restore'

22) The browser will now display 'OK' and on the camera display, the STD picture style will be displayed (top left next to the Mode indicator)

23) Repeat 17-22 to switch between enabling and disabling Cinelike D

 

If it does NOT connect the first time, then just let it time out and repeat from the top. Once it has successfully connected it will store the connection and from thereon in will connect first time every time.

46 minutes ago, Grimor said:

   1 hour ago,  BTM_Pix said: 

But if the camera doesn't like or understand the command it will reject it so its not fully predictable or even changeable.

----------------

 

First of all, THANK YOU.

 

So, if its not predictable, is safe to try a luck?

 

By the way, just to be absolutely clear, the quote of mine that you've used there relates to a different conversation regarding trying to guess at additional commands to get them working.

It has nothing to do with what I've shared regarding the Cinelike D stuff as rest assured I would not share something without testing that it didn't break my own camera first.

25 minutes ago, seppling said:

AH, ok - the first speedbump is figured out. I wasn't going to Wi-Fi direct connect on my phone. The two devices are now directly connected via wifi and I was able to successfully initiate the handshake. However, I'm now receiving a 404 Page Not Found error when attempting to connect. Will continue to try and establish a connection via the web browser page.

OK, well that sounds like if you got the handshake going then the camera is timing out, dropping its wifi transmission and your phone is falling back to a different wifi network and giving the 404 error because its connected to the internet while the page is referring to the address of the camera.

This is a positive sign as it should mean if you start the process again, the connection will have been registered and you'll be able to get through on the next attempt.

Share this post


Link to post
Share on other sites
7 hours ago, BTM_Pix said:

the quote of mine that you've used there relates to a different conversation regarding trying to guess at additional commands to get them working

 

I know, thanks again

Share this post


Link to post
Share on other sites
6 hours ago, gatopardo said:

Is it working for your LX100? 

The LX100 accepts the Cinelike commands and changes it's colour profile to something unusual.

I'll look at it again at some point as it would be a very cool thing to have on there I think. 

Share this post


Link to post
Share on other sites

As expected, only a handful of users even remotely interested in Cinelike D. Pretty disheartening. 

@tupp Not sure whether you've got a significant other or not, but the eye candy here might help you forget Mexican food altogether. I'm pretty sure there are some good Mexican eateries in Saigon, though.

Share this post


Link to post
Share on other sites

I tried it, and it seemed a little difficult at first, but in the end, I realised the instructions made it very simple. 

My observations:
1. Cineline D is actually Pretty Flat. Not very, but about 1/2 to 1 stop more Dynamic Range than Natural. Also, the shadows seem to benefit more than the highlights.

2. The Name of the Profile (Cinelike V, just like Natural, Portrait etc) doesn't appear when it is engaged (it means Blank, though the various values of colour, etc can be changed or adjusted). 

3. Focusing and other buttons on the camera itself become difficult to engage. As in, they cannot be engaged, except through app (?). 

EDIT:

Fixed Pattern Noise is HUGE in Natural, in comparison with Cinelike D. And, Cinelike D seems very promising for grading. 

 

Share this post


Link to post
Share on other sites

"Packet Capture" (free from the Play store) doesn't require root access if anyone wants to delve in.

1 hour ago, sanveer said:



My observations:

3. Focusing and other buttons on the camera itself become difficult to engage. As in, they cannot be engaged, except through app (?). 

 

Not my experience with this at all.

Its made no difference at all to the responsiveness of any of the controls of the camera.

Are you referring to when you still have it connected to the wifi or something?

1 hour ago, sanveer said:


My observations:
2. The Name of the Profile (Cinelike V, just like Natural, Portrait etc) doesn't appear when it is engaged (it means Blank, though the various values of colour, etc can be changed or adjusted). 

 

This is expected and described earlier in the thread. Its actually the way to confirm its worked ;)

As per the recommendation, consider saving the Cinelike profile as C1 and then the Standard profile as C2.

This makes it really simple to switch between them in camera if required.

Hope that helps.

Share this post


Link to post
Share on other sites
2 hours ago, BTM_Pix said:

"Packet Capture" (free from the Play store) doesn't require root access if anyone wants to delve in.

Not my experience with this at all.

Its made no difference at all to the responsiveness of any of the controls of the camera.

Are you referring to when you still have it connected to the wifi or something?

This is expected and described earlier in the thread. Its actually the way to confirm its worked ;)

As per the recommendation, consider saving the Cinelike profile as C1 and then the Standard profile as C2.

This makes it really simple to switch between them in camera if required.

Hope that helps.

I don't remember if this was asked, but can you also change the parameters of CineLikeD... dial down sharpness, noise reduction... ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×