Jump to content
kidzrevil

Petition for Samsung NX1 hack

Recommended Posts

1 hour ago, Pavel Mašek said:

stick to original Vasile's BT hack becuase it basically fixed most important issue to me of NX1 (macroblocking) and I am fine with it (except longer booting)

Yeah, I understand this it's cool, but I must say that latest versions of KS-pack are very, incredible fast compare even to early versions of KS-pack and of course to vasiles bitrate hack. It's because that now KS-pack use internal memory of camera to locate the scripts, now they are not on sd-card, so it works sooooo much faster than sd-card based scripts. Scripts are basically the same with some optimisations.

1 hour ago, Pavel Mašek said:

I really appreciate your hard work as tester - it is really great contribution.

Thanks :) I think there lot of guys do the same, not only me of course, and even little help is help, so big thanks from me to all who seek any errors and inconveniences with this project, suggest new ways and produce other add-ons to the hack.

1 hour ago, Pavel Mašek said:

BTW  :-) - my name is Pavel (first name) Masek (surname). MaÅ¡ek corrupted because of unsupported diacritics from FB login

Oh, sorry about that, I know where I did mistake yesterday. Thanks for clearing it out, now I will use your name properly :)

Share this post


Link to post
Share on other sites
EOSHD Pro Color for Sony cameras EOSHD Pro LOG for Sony CamerasEOSHD C-LOG and Film Profiles for All Canon DSLRs
1 hour ago, Pavel Mašek said:

\k becuase it basically fixed most important issue to me of NX1 (macroblocking)

Wasn't macroblocking fixed with higher bitrate hack, regardless of version? (I'm asking because I haven't had the chance (slow card) to try any of the hacks.)

Share this post


Link to post
Share on other sites
27 minutes ago, SR said:

Wasn't macroblocking fixed with higher bitrate hack, regardless of version? (I'm asking because I haven't had the chance (slow card) to try any of the hacks.)

Latest versions since 1.47 of KS-pack are not only faster with gui, it also seems to be faster with sd-cards due some optimizations in scripts. I can say that with first 1-2-3 versions of vasiles bitrate hack I can reach 140-180 mbps (depends on the card) and with latest versions of NX-KS I can use 190-260 mbps with pretty much the same cards.

But I really, really recommeng to read all info about this on dpr or github since guys mostly conversate there. it's not about that you can't use the hack without reading, of course not, you can, but there is known issues that not only mentioned but resolved in this threads, and there is unresolved ones, which good to be aware of. But in most cases all NX-KS works very good, bitrates, focus options, overall stability - is fine now

I can manage to use automatic focus pull with MF-switched lense during the video record with 120 mbps bitrate via Otto's script in NX-KS pack, which is VERY cool option. Same thing via telnet works faster for now, but with new optimisations I think there is a good chance to reach very-very good stability and speed in this. It looks just incredible, you know.

Share this post


Link to post
Share on other sites

My camera locks up alot with version 1.54 of the kino seed hack. Sucks cuz I gotta take the battery grip off and take all the batteries out. Otherwise the hack works flawlessly. Occasionally however i'll get clips with dropped frames or missing audio. Looking for the sweet spot that gives your footage the advantage of higher bitrates minus the insane file sizes and computing power required to edit the footage. Im thinking maybe 160 mbps maybe the ideal compromise. All we need to do now is get rid of the noise reduction and the hack will be even more beneficial

Share this post


Link to post
Share on other sites

So on my vacation I shot a lot with my new NX500 and Kino Seed hack testing a lot of different in-camera colour settings, I use 2.5k mostly.

I noticed it cannot go above 140mbps but 2160p does 200mbps just fine, is it the same for everyone? I use my Lexar 300x 128GB card

Share this post


Link to post
Share on other sites
17 minutes ago, SMGJohn said:

So on my vacation I shot a lot with my new NX500 and Kino Seed hack testing a lot of different in-camera colour settings, I use 2.5k mostly.

I noticed it cannot go above 140mbps but 2160p does 200mbps just fine, is it the same for everyone? I use my Lexar 300x 128GB card

How you use 2.5k? i active it in the menu but i dont know how i can recording with it.

Share this post


Link to post
Share on other sites
45 minutes ago, Daniel Galli said:

How you use 2.5k? i active it in the menu but i dont know how i can recording with it.

It replaces the 480p VGA with 1440p HEVC, when you have ticked it off in Kino's menu, you need to go select VGA were you select your resolutions in the camera menu (not Kino's Mod Pack menu), you will know it uses 2.5k when you see the widescreen letter boxing instead of the 4:3 letter boxing on the sides.

I highly recommend using 2.5k primarily because it consumes less power and the rolling shutter is less noticeable you also get finer grain details with no NR screwing up things for you. 

Also change the bitrate for the VGA mode to 140mbps in Kino's Mod Pack Menu, that is the most stable for me with no lockup or stopping duo to slow SD card

Share this post


Link to post
Share on other sites
4 hours ago, SR said:

Wasn't macroblocking fixed with higher bitrate hack, regardless of version? (I'm asking because I haven't had the chance (slow card) to try any of the hacks.)

Yeah higher bitrate fixes it. Im working on in camera settings that will further take advantage of the higher bitrates

Share this post


Link to post
Share on other sites
35 minutes ago, SMGJohn said:

It replaces the 480p VGA with 1440p HEVC, when you have ticked it off in Kino's menu, you need to go select VGA were you select your resolutions in the camera menu (not Kino's Mod Pack menu), you will know it uses 2.5k when you see the widescreen letter boxing instead of the 4:3 letter boxing on the sides.

I highly recommend using 2.5k primarily because it consumes less power and the rolling shutter is less noticeable you also get finer grain details with no NR screwing up things for you. 

Also change the bitrate for the VGA mode to 140mbps in Kino's Mod Pack Menu, that is the most stable for me with no lockup or stopping duo to slow SD card

thanks a lot dude! i activate it and works, but is possible to record 2.5k in 24p?

Share this post


Link to post
Share on other sites
4 hours ago, Daniel Galli said:

thanks a lot dude! i activate it and works, but is possible to record 2.5k in 24p?

Sadly not, its 25fps.

Why would you want 24fps? You can always just pull down 25fps to 24fps in editing software, its only 1fps difference, I do not really recommend it from personal experience, 24fps creates nasty choppy effect when you do pans and tilts, its also very poor when there is a lot of action in the scene, 25fps negates that a bit.

But no fps choice with 2.5k yet, from what I understand its either 25fps or 30fps depends if you use PAL or NTSC.

So do a pull down if you want 24fps but I would not do it if I were you, we in Europe almost always shot our films in 25fps, its mostly in Hollywood they do 24fps

Share this post


Link to post
Share on other sites
4 hours ago, vaga said:

@vasile @kidzrevil @v.paul

There's no way to choose 2.5k 24fps? What if you replace one of the other resolution slots?

They could just replace the 720p modes except the 100/120fps one, imao who uses 720p nowadays. There is also the 480p HEVC mode too. 

Share this post


Link to post
Share on other sites

Is there any hope in disabling the NR in video mode so far? 

The 2.5k mode on NX500 is a bit buggy here and there but the lack of NR just makes the image more pleasing to me specially in dark areas, also appears to be lacking in-camera sharpness which is nice for us who likes to sharpen in post.

Share this post


Link to post
Share on other sites
7 minutes ago, SMGJohn said:

Is there any hope in disabling the NR in video mode so far? 

The 2.5k mode on NX500 is a bit buggy here and there but the lack of NR just makes the image more pleasing to me specially in dark areas, also appears to be lacking in-camera sharpness which is nice for us who likes to sharpen in post.

Im PRAYING we find a way to disable nr. I feel like the true image enhancements of the higher bitrates will come to light the day this does happen. Maybe the secret lies with how the camera processes the image with DIS active or DCI 4k ? Ive been shooting in the DCI mode and noticed less sharpening artifacts. I guess the sensor doesnt need to downscale as much so the image is softer. Idk just a hunch

btw the image looks phenomenal in DCI. Truly organic

Share this post


Link to post
Share on other sites
17 minutes ago, kidzrevil said:

Im PRAYING we find a way to disable nr. I feel like the true image enhancements of the higher bitrates will come to light the day this does happen. Maybe the secret lies with how the camera processes the image with DIS active or DCI 4k ? Ive been shooting in the DCI mode and noticed less sharpening artifacts. I guess the sensor doesnt need to downscale as much so the image is softer. Idk just a hunch

btw the image looks phenomenal in DCI. Truly organic

From what I have read early on was that 4k is upscaled 2160p and cropped in-camera, this was made from the conclusion that it lacks sharpness and had more aliasing than UHD. 

Whether this really is the case is debatable because I have no idea how it really works, it could be true line skipping for all I know. 

When I shoot 2160p or 4k in NX500 I get fine noise grain like in 1440p mode, its just smaller grain which is expected duo to higher resolution. Why is this? I use Kino's Mod Pack 1.62m, was this a standard feature on the NX500 before the hack? I am too lazy to uninstall and reinstall on my vacation just to check it, can any NX500 owner confirm with me if this was the case? 1080p mode has the ugly NR as we know it, hurts me everytime i look at that blue swirling death atoms on high ISO videos shot from NX1.

LEFT - 1440p mode from NX500 (140mbps) | RIGHT - 2160p mode from NX500 (160mbps)

vlcsnap-error983.pngvlcsnap-error918.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...