Jump to content
Andrew Reid

LEICA SL2 - showstopper of a battery problem

Recommended Posts

GFX13586-2-scaled.jpg

I was very excited for the Leica SL2 and bought mine in December 2019. I have been using it ever since and it is every bit as beautifully designed as the previous model, but this time with high-spec 4K video features, IBIS and an anamorphic 5.5K mode. As usual, I paid the full retail price out of my own pocket and didn't take a camera on loan. This is something I am now regretting because the SL2 has a major show-stopping problem which effects ALL models out there and isn't isolated to mine.

NEW BLOG POST:

https://www.eoshd.com/leica/leica-sl2-has-power-flaw-and-should-be-recalled-until-then-i-recommend-not-using-for-professional-4k-shooting/

Share this post


Link to post
Share on other sites
EOSHD Pro Color for Sony cameras EOSHD Pro LOG for Sony CamerasEOSHD C-LOG and Film Profiles for All Canon DSLRs

I appreciate the heads up on this. You might remember in the past I asked you if you had any SL2 footage you could share as I had been considering this camera for a bit. Guess it's backorder status and lack of footage online saved me.  

Share this post


Link to post
Share on other sites

Yes. It's a case of you must NOT buy it until this problem is fixed. It really is a show-stopper.

I've lost shots just testing it - imagine losing the money shot on somebody's paid shoot with a £5300 camera. It was going to come to Barcelona with me to film the F1 but ended up taking the Fuji GFX 100 instead - it never let me down and goes for ages on the twin batteries.

Share this post


Link to post
Share on other sites

On a side line: Pretty sure it‘s not a good idea to publish information about health issues of an identfiable person, most defenitely not without consent. This person has a right for privacy too...

Share this post


Link to post
Share on other sites
7 minutes ago, Michi said:

On a side line: Pretty sure it‘s not a good idea to publish information about health issues of an identfiable person, most defenitely not without consent. This person has a right for privacy too...

The person in question detailed it himself on Instagram to be fair.

 

Share this post


Link to post
Share on other sites

@Andrew Reid Looking at their specs on the website there is enough to make a claim under the Sale of Goods Act as it not being fit for purpose.

The only restriction noted to video is an overall record time limit with nothing being described about power.

You have to give the retailer the opportunity to fix it so, well, that won't be happening of course so you should be able to get a full refund.

Share this post


Link to post
Share on other sites

Such a damn shame, as it's a nice camera. Lovely to use and to pick up, great image... when you can get any images.

At first the lack of MC-21 compatibility was disappointing shenanigans

But now I realise the camera is just flat out broken.

They should be all over this issue fixing it, but Leica don't seem to care.

Share this post


Link to post
Share on other sites
4 minutes ago, BTM_Pix said:

The person in question detailed it himself on Instagram to be fair.

Thank you for this information. I didn‘t know that. I guess it‘s another story then. 

Share this post


Link to post
Share on other sites

Andrew normally i would never bring this up but you have "This is something I am NOT regretting because"...     Sorry about the camera,  Hope it works out for you in the end.

Share this post


Link to post
Share on other sites

A bit off topic, but how do you find the Panasonic S pro 50? Thinking about using it on the S1H. I'm debating between that and the Leica SL 50 Summilux. Thanks and sorry to hear about the issues your having Andrew, hoping Leica takes care of you. Best wishes. 

Share this post


Link to post
Share on other sites

I doubt that the battery can be improved to the point that a replacement will not suffer the same problem ... lack of

current from a very power hungry camera ... the should have had an external power point ... not just the USB-C input.

However ... this may be a potential solution ...

https://www.bhphotovideo.com/c/product/1316194-REG/tether_tools_crdtap_d_tap_connector_to_usb.html

I use this to run from d-tap off my AB Gold mount batteries ... in my case I can go 2.5A to USB-C or use the Tether Tool Case Relay kit

to a battery insert ... the advantage of the Case Relay is that it allows hotswapping of the battery due to an inline small battery that charges while

you power the camera. They also have a powerbank battery that supplies 26,800mA and 87W:

 

https://www.bhphotovideo.com/c/search?Ntt=tether tools power bank&N=0&InitialSearch=yes&sts=ps

Shame to sideline such a beautiful camera ... do not expect that Leica will rectify this ... one of the reasons I sold my SL

and replaced it with a different camera manufacturer.

 

 

Share this post


Link to post
Share on other sites

Looks like they didn't test the camera enough before releasing it.
Interested to see how they resolve this. Maybe a firmware update (lower threshold) to mask it? Recall?

Share this post


Link to post
Share on other sites
3 hours ago, Andrew Reid said:

Yes. It's a case of you must NOT buy it until this problem is fixed. It really is a show-stopper.

I've lost shots just testing it - imagine losing the money shot on somebody's paid shoot with a £5300 camera. It was going to come to Barcelona with me to film the F1 but ended up taking the Fuji GFX 100 instead - it never let me down and goes for ages on the twin batteries.

For sure. Strange they haven't responded to you on the issue which is almost worse than the issue itself.

Losing shots to power failure is definitely unacceptable. Maybe your blog post will induce a response.

Share this post


Link to post
Share on other sites

Leica haven't responded to anybody about it. Tons of users with the same issue

https://www.l-camera-forum.com/topic/306288-4k-recording-with-low-battery/

It's disgraceful.

I want a refund! Or a working camera. Whichever comes first.

Share this post


Link to post
Share on other sites

I have the exact same issue and I am using bother the Panasonic 24–70/2.8 and the 70-200/2.8 L Mount lenses and shooting video is a total crap shoot. So I decided to focus more on stills with the camera and when using high burst mode I had the exact same issue

i reached out to Leica USA last November and have gotten a response from them

 

Share this post


Link to post
Share on other sites

No response since NOVEMBER?

That is appalling from such a well know company. Are they trying to bury the issue and hope the publicity doesn't develop before the fix comes out? I can only speculate. But I want it fixed. Otherwise the £5k camera goes back to Wetzlar with a polite note for a refund.

Share this post


Link to post
Share on other sites
57 minutes ago, Andrew Reid said:

No response since NOVEMBER?

That is appalling from such a well know company. Are they trying to bury the issue and hope the publicity doesn't develop before the fix comes out? I can only speculate. But I want it fixed. Otherwise the £5k camera goes back to Wetzlar with a polite note for a refund.

And I had almost sold my M10 and S1H, sacrificed fast rangefinder focusing to dingy focus peaking in EVF for SL2. Boy, I am glad I didn't do it. It was the moire that kept me away, but I must admit I was ready to swallow that too. 
Regarding Leica not responding, well, that's nothing new. It's their way or no way, and that's perfectly fine. They should issue you a refund, though. One of the camera's main features is not usable. 

Share this post


Link to post
Share on other sites

It is not just 4k, the average time shooting stills is much reduced by power drain on the  battery. It was bad on my SL it is even more significant on my SL2 replacement especially when using the Sigma 45mm f2.8 and Panasonic 70-200 f4 and made even worse by adding the DMW-STC14 converter. I am forced to switch to manual M lenses lenses with OIS off in order to not be left with a dead camera too often.  Problem appears less acute with Leica's own L lenses but even then my 90 APO-SL causes issues when using the body OIS. Further firmware solutions and a more capable battery are urgently required. It's a proud company. Many of its people are as helpful as they can be but it appears they are powerless up against significant product design issues particularly critical using 3rd party L lenses. I get less annoyance from my M10 but then only as long as I use my EVF sparingly. Sad this... and very costly both in reliability, reputation and financial outlay... even for a long term customer.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...