Jump to content
kidzrevil

Petition for Samsung NX1 hack

Recommended Posts

19 minutes ago, RieGo said:

just tried "st app nx record start" and "st app nx record stop". works just as expected, starts and stops video recording. but i have no clue how to use the resolution parameter... i tried but couldn't get to change anything.
is this even what you are thinking about? i have no clue :grin:

resolution [show,name] -> this arguments seem like only predefined resolutions can be used

resolution [show, name] means you can use resolution show or resolution name.

Presumably resolution show would list available names to be used as "name" parameter for resolution "name"

Share this post


Link to post
Share on other sites
EOSHD Pro Color for Sony cameras EOSHD Pro LOG for Sony CamerasEOSHD C-LOG and Film Profiles for All Canon DSLRs
27 minutes ago, vasile said:

resolution [show, name] means you can use resolution show or resolution name.

Presumably resolution show would list available names to be used as "name" parameter for resolution "name"

alright, my bad. anyways "resolution show" doesn't give any output on terminal. maybe it's just in log or something...

i'm just running the video tests. just looks like a bunch of small videos in different resolutions...

btw: at "basic" and "full" test my battery turned from 50% to 0% in like 5 minutes until camera turned off... maybe that's part of the test or my battery is broken :grin:

Share this post


Link to post
Share on other sites

Not all of the functions of st work, the st binary does hardly anything, it offloads it to other binaries (di-camera-app mostly) and libraries (various ones). 

Some of the functionality is not even declared in st but in di-camera-app, etc. 

Share this post


Link to post
Share on other sites
14 minutes ago, Jorgen Gerstel said:

Bitrate test 180MBit/s on Komputerbay card

It seems only 1080p50/60/100/120 benefits the most out of the bitrate increase, in 2160p I could not notice any difference other than noise being tad finer detailed but its insignificant.

Also NX1 HEVC codec is Level 5.1 which only allows for max 160mbps so any higher would be pointless as its not presented in the camera

Share this post


Link to post
Share on other sites
16 minutes ago, SMGJohn said:

Also NX1 HEVC codec is Level 5.1 which only allows for max 160mbps so any higher would be pointless as its not presented in the camera

 

On 6.4.2016 at 7:09 PM, tugela said:

It is just a specification. There is no reason why the software can't go higher, just if it does it will generate an out of spec file.

This is still true. the final file HAS 180MBit/s so they ARE used. This is no fill up data or anything like this.... well i can't proof that, but i'm pretty sure there is no such thing as filling data in mp4 containers... only television packets use filling data because they have to use a defined constant data rate.

sorry, that was a lot of "filling data" but "filling data" is the only way i know to make bits disappear :grin: 

Share this post


Link to post
Share on other sites

Did a short 1 min test with 160 mbit. Camera was very responsive this time. The macroblocking I remember is essentially gone, but the biggest improvement actually seems to be in motion cadence. No tearing or anything even with a manual non-stabilized lens. 

Has anybody done any longer stress tests?

I'm thinking of shooting a short film (just a personal project) with this hack tomorrow... but I'm worried about general stability and somehow bricking the camera, running it hacked for two long days. Any advice?

Share this post


Link to post
Share on other sites
46 minutes ago, André Eriksson said:

Did a short 1 min test with 160 mbit. Camera was very responsive this time. The macroblocking I remember is essentially gone, but the biggest improvement actually seems to be in motion cadence. No tearing or anything even with a manual non-stabilized lens. 

Has anybody done any longer stress tests?

I'm thinking of shooting a short film (just a personal project) with this hack tomorrow... but I'm worried about general stability and somehow bricking the camera, running it hacked for two long days. Any advice?

I have run for 30 mins @ 160 mbit with no problems

Share this post


Link to post
Share on other sites

I was more meaning test the line that is the full integration video record test and log what happens. Which modules the pmu activates, the file output etc.

So "st app nx record run full"

 

Ill test it when Im done work tonight though. There is a lot of code to go through in the di camera app, and I did maybe 1/4 of it last night Found a few things like that. Mainly looking into the hevc block and that jazz.

I do like how quickly the scripting side of things is going though! So much progress so quickly! 

Share this post


Link to post
Share on other sites

People asked about possibility to switch between EVF and LCD during video (apparently not working on NX1). Since I have NX500 I cannot really switch anything but what is described here works as described :)

st app bb [lcd|evf|tv][on|off|osd|video]

For example, to show only clean video on back LCD: st app bb lcd video

To show only OSD (without video): st app bb lcd osd

To turn it off completely: st app bb lcd off

To show everything as normal: st app bb lcd on

Now, someone with NX1 could try and report back if these things work and if this can solve the problem of switching the LCD/EVF during video.

https://github.com/ottokiksmaler/nx500_nx1_modding/blob/master/Control_LCD_EVF.md

Share this post


Link to post
Share on other sites
37 minutes ago, Otto K said:

People asked about possibility to switch between EVF and LCD during video (apparently not working on NX1). Since I have NX500 I cannot really switch anything but what is described here works as described :)

st app bb [lcd|evf|tv][on|off|osd|video]

For example, to show only clean video on back LCD: st app bb lcd video

To show only OSD (without video): st app bb lcd osd

To turn it off completely: st app bb lcd off

To show everything as normal: st app bb lcd on

Now, someone with NX1 could try and report back if these things work and if this can solve the problem of switching the LCD/EVF during video.

https://github.com/ottokiksmaler/nx500_nx1_modding/blob/master/Control_LCD_EVF.md

ok,

If you go into movie preview or record a movie on the NX1 the video and osd are locked to the LCD or EVF that you were on when you entered the mode.

With this you can turn on and off video, osd, all but if you try to turn on the other non used mode it will not work

For example if I go into video standby on the LCD

st app bb lcd video - gives only video on the LCD
st app bb lcd osd - gives only osd on the LCD
st app bb lcd all - gives both video and osd on the LCD

If I now do a st app bb lcd off - this switches off the LCD but the EVF isn't enabled.

If I now do a st app bb evf on - this switches the LCD back on not the EVF

in fact it will not change anything on the EVF unless I take it out of standby and manually switch to the EVF by pressing the EVF button (which is diabled in standby and recording)
once it is pointing to the EVF then all the commands you send it be they EVF or LCD then take effect on the EVF.

 

7 minutes ago, hirsti said:

ok,

If you go into movie preview or record a movie on the NX1 the video and osd are locked to the LCD or EVF that you were on when you entered the mode.

With this you can turn on and off video, osd, all but if you try to turn on the other non used mode it will not work

For example if I go into video standby on the LCD

st app bb lcd video - gives only video on the LCD
st app bb lcd osd - gives only osd on the LCD
st app bb lcd all - gives both video and osd on the LCD

If I now do a st app bb lcd off - this switches off the LCD but the EVF isn't enabled.

If I now do a st app bb evf on - this switches the LCD back on not the EVF

in fact it will not change anything on the EVF unless I take it out of standby and manually switch to the EVF by pressing the EVF button (which is diabled in standby and recording)
once it is pointing to the EVF then all the commands you send it be they EVF or LCD then take effect on the EVF.

 

I have tried switching the evf internally using the st key and sys_param but they don't change whilst in standby or recording.

Share this post


Link to post
Share on other sites
On 7. 4. 2016 at 1:01 AM, Otto K said:

Cross post from dpreview:

As promised I was working on alternative way to run scripts off the SD card without entering the factory mode (as it limits several functions important to me).

Full text here

https://github.com/ottokiksmaler/nx500_nx1_modding/blob/master/Running_scripts_without_factory_mode.md

What it does: it modifies your root filesystem in camera so it starts a shell script from SD card (if present) every time you start WiFi.

Yes, it's rough. This is a first release just to enable everybody else to test and play around.

Touchscreen works.

Bluetooth works.

Camera works faster than in factory mode.

This might help with increased bitrate as well (don't know, can't test).

Have fun :)

Otto, sorry again for dumb question - do you think there will be any different method (safest, without using telnet, even for IT dumbs like me) how to do that? I really like this approach but not 100% sure if should I try it or rather wait a few weeks for something easier and "safer"... Thank you!

Share this post


Link to post
Share on other sites
12 hours ago, /Chop N Shoot Films/ said:

Is MJPEG encoding still on the table?

I am for MJPEG but imo, the noise reduction in video mode is far more important now as its completely cancerous. Its impossible to film above 800ISO in 1080p without having a video footage that looks like its from 1997.

2160p can do about 1600ISO before it looks awful, the NR seem to cause serious issues in destroying details in dark areas too. Which means you cannot underexpose at all before ending up with ruined images with lost details and the camera overexposes quite easily and balancing this literally requires a degree in science...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...