Canon blocking Magic Lantern on latest 5D Mark III bodies

5D Mark III - Magic Lantern hack
Goodbye world?

Canon look to have blocked Magic Lantern and new 5D Mark III bodies which won’t roll back to older firmware.

Users are presented with an error saying “firmware older than 1.3 on the card, update using newer version”.

Source – Magic Lantern forum Via Canon Rumors

Magic Lantern on the 600D

If this is a move to block Magic Lantern it won’t generate very much good will.

In my opinion, as long as they are aware of the warranty being void, users can do what they like with their cameras. They can modify them, take them apart, use them as door stops. They paid the money, their camera is their own.

Panasonic once encrypted the GH1 firmware on more recent bodies to leave the factory, only to reverse the policy when it came to the GH2 which allowed the community around the hack to flourish. It was a really strong selling point of the camera.

I also know a lot of people (myself included) who kept hold of their 5D Mark III long after I would otherwise have sold it, purely to run Magic Lantern’s features such as raw video recording.

Magic Lantern Unified 5D Mark II - Movie mode

This is breaking news and the situation could change. It may be that Canon haven’t encrypted the new firmware at all and Magic Lantern will update their software to support it (no guarantees though), but the circumstances surrounding its arrival are rather auspicious for a blocking tactic…

  • Cannot roll back to V1.2.3 (supported by Magic Lantern)
  • No download of V1.3.3 on Canon’s website
  • Seemingly no news or user reports of feature changes or improvements using the new firmware

Let’s hope Canon have not changed their policy towards Magic Lantern and will continue to allow users to do what the hell they like with their own cameras.

Until then, if you want to run Magic Lantern be mindful of buying a brand new Canon body to run it on. Better to buy one used with the firmware confirmed as supported by Magic Lantern.

Canon’s attitude towards apps is out of step with 2015. It’s the camera-equivalent of Apple banning the entire App Store.

Comment on the forum