Jump to content
Sign in to follow this  
BTM_Pix

Problem With Samsung T5 Drive After Using It With iPad

Recommended Posts

So I've been using a T5 drive with an iPad to import some footage without any problem for a while.

Tonight (when I really, really fucking need it obviously) the drive is no longer readable in anything OTHER than the iPad.

Tried on different Macs and different Android devices and the drive LED lights up but it doesn't show up.

Put it back in the iPad and its fine.

Seems like the iPad has put some sort of lock on it but as there is no eject disk option I've tried different approaches such as completely powering down the iPad with it connected, closing the File app and just yanking the power out and absolutely nothing STOPS it working again in the iPad or MAKES it work in anything else.

If anyone has a fix then to say I would be grateful would be an understatement.

I can't stress enough how much I do not want to hear any sort of variation of "have you backed up the data onto another device" ;) 

Share this post


Link to post
Share on other sites
EOSHD Pro Color for Sony cameras EOSHD Pro LOG for Sony CamerasEOSHD C-LOG and Film Profiles for All Canon DSLRs

Can you install Data Rescue on your mac? Not to rescue your data, but in my experience it can read anything even if Disk Utility can't, and you can try to mount it from there. I think there's a free version that limits the amount you can backup, but like I say, this is to see if you can mount the drive.

https://www.macupdate.com/app/mac/10259/data-rescue

 

Share this post


Link to post
Share on other sites
24 minutes ago, Anaconda_ said:

Can you install Data Rescue on your mac? Not to rescue your data, but in my experience it can read anything even if Disk Utility can't, and you can try to mount it from there. I think there's a free version that limits the amount you can backup, but like I say, this is to see if you can mount the drive.

https://www.macupdate.com/app/mac/10259/data-rescue

 

I'll take a look at that tomorrow when I've calmed down!

Cheers

Share this post


Link to post
Share on other sites

Well...

The recovery software route didn't work.

Attached the drive to a PC and...nothing.

Even connected it the Pocket4K and Pocket6K who were equally unimpressed.

Connected it to the USB port of the WD Wireless Pro (aka the worst wireless backup hard drive in western Europe 2019) and it welcomed it with open arms.

I'm currently copying the vital stuff onto that.

If my previous backup efforts with that drive are anything to go by then it will take another 3 or 4 attempts to get them all across but I'll take that in this instance.

Really weird problem though.

Share this post


Link to post
Share on other sites
16 minutes ago, KnightsFan said:

What exactly happens when you plug the T5 into a Mac or PC? Does it show up in the device manager (or whatever the Mac equivalent of that is)? Any noises or alerts? What is the drive formatted in--exFat, HFS, etc?

Absolutely nothing other than the drive light coming on.

Doesn't show up in Finder or System Report. 

On Android it doesn't show up as an OTG device as it should be doing.

Yet there it is in iOS bold as brass in Files and also as an external source on the WD Crankdrive which often has trouble finding its own internal one let alone an external one connected to it.

Previously, the T5 had happily been trundling around between Mac, iOS and Android without any issues whatsoever.

Its very unusual and I can't find anyone else online having a similar problem with it although being able to mount and use them in LumaFusion etc is a relatively recent development so I'm not sure there is a big sample out there.

Share this post


Link to post
Share on other sites

Does it show up in Disk Utility at all? If so, does it give any information? I ran into issues like this a LONG time ago when I unplugged a drive from a Windows computer without ejecting it, and then Mac wouldn't show it automatically. I think in that case I could still see it in Disk Utility and it gave some information about the drive.

Also, have you tried a different cable? I have a Micro HDMI cable that works everywhere, except it suddenly stopped working with my NX1 about a year ago.

Do you have other USB devices plugged into your Mac that would be forcing it to only allocate USB 2.0 resources to the T5? I would expect it to still work, but it's another easy thing to try.

Share this post


Link to post
Share on other sites

Yeah, absolutely no sign of it in Disk Utility.

I've tried it with multiple cables, multiple Macs, multiple Android devices with multiple OTG adapters, through USB3 hub, USB2 hub, Pocket4K, Pocket6K and the only devices it wants to play ball with is the iPad and ,somewhat inexplicably considering how crap it usually is, the WD Wireless Pro.

As it happens of course, this gives me the chance to (slowly) back up the T5 directly to it so for once in its miserable existence its actually proved its worth.

Definitely seems like some sort of issue related to there not being a defined eject procedure on the iPad but its worked perfectly well thus far as have 2 different T5s I've used for the same purpose.

 

Share this post


Link to post
Share on other sites
Just now, Emanuel said:

But have you tried with multiple recovery software? On Windows too?

No, there is no need to in terms of data recovery now as the drive is visible to the WD Wireless Pro on its USB expansion port so I'm able to copy the files to that.

I'll ponder why it won't mount on anything else when I'm through with actually using the files it was holding hostage ;)

Share this post


Link to post
Share on other sites

I guess you won't be able to get it before you shall have to end formatting the thing... Fortunately, data is safe in good hands at least : ) Yesterday night I lived a similar trouble with material I'll still need to show to Glenn! @mercer LOL : -)

Recovery software aka Easeus Wizard Technician version saved my day and a few years from past, as well some others yet to come though!

Share this post


Link to post
Share on other sites

I know many will not connect a SD card to a Mac unless it is physically locked as the OS tend to write files on it that may

corrupt what else is there. It may be that the IOS did something similar .... and as far as I know there is no lock state on

writing to a T5.

 

If the WD Wireless is accessible through the net can you format the T5 through its connection after you have rescued the files?

Share this post


Link to post
Share on other sites

Hi BTM_Pix,

There's an ongoing thread over at Samsung's Community forum regarding the T5 not working in Catalina (MacOS 10.15)...

Solved: T5 SSD not working with macOS 10.15 Catalina - Samsung Community - 860123:

https://us.community.samsung.com/t5/Monitors-and-Memory/T5-SSD-not-working-with-macOS-10-15-Catalina/td-p/860123

...and even though that thread's title states that the issue is solved apparently plenty of folks are still having issues after applying (or trying to apply) the solution...

https://us.community.samsung.com/t5/Monitors-and-Memory/T5-SSD-not-working-with-macOS-10-15-Catalina/m-p/939900#M3042

...(TLDR: Install Samsung v1.6.6) not encouraging news.

Please keep us posted as to how you make out, I just purchased two of these (1TB's) as gifts for my gals for the holidays to use with their iPad Pros and MBPs and now I'm thinking that maybe I should be looking at another brand's SSD for them. Oofah.

Best of luck, :)

Jimmy G

Share this post


Link to post
Share on other sites

I had a similar problem on a recent shoot with a Pocket 4K.

 

The T5 drive was first accessed by the DIT's mac laptop, which put on the T5 drive all of the Apple FS hidden files.

 

I was able to mount the drive on my Linux-booting Chromebook several times, but, unfortunately, I accidentally unplugged the drive without first unmounting it.  In doing so, I apparently borked one of the hidden Apple FS files, because when I subsequently tried to mount it, I kept getting an error message that one of those Apple FS files was corrupted.

 

When we connected the T5 drive to the first Mac laptop that accessed it, it had no problem mounting.

 

Of course, you can reformat the drive on your Ipad after you have backed up all the files, correct?  If not, I would suggest downloading the open source Parted Magic live OS.  There are plenty of rescue/drive-accessing live OS's out there, but Parted Magic sometimes works when others don't.  Parted Magic should be able to access your drive and format it.  It costs $11 to directly download the compiled version, but there are usually several torrents available for free.  Or, since it is open source, you could compile it yourself.  ☺️

Share this post


Link to post
Share on other sites

Thanks for all the input.

I'm tempted to just say "oh well its fucked" and throw it away after I've got everything off it but its spooking me a bit about whats happened.

These T5 drives are becoming ubiquitous for me because of the Blackmagic cameras and editing on LumaFusion as well as just as general work portability so I have quite a few of them so I'd like to get to the bottom of what's caused it.

Oh well, I'll have some free time at some point in 2024 so it will have to wait until then.

 

Share this post


Link to post
Share on other sites

To be fair, the Apple products are all working fine and its the Samsung one thats fucked.

Oh, tell a lie, its done its best to take the WD Wireless Pro drive with it now.

Although that thing is so flaky that trying to work out exactly whats caused it to not be currently working is like trying to establish which particular baked bean in the tin made you fart.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...