Jump to content

Viltrox EF-M2 Disconnecting Problems


Recommended Posts

I'm having a very strange problem with my Viltrox EF-M2 adapter. It "disconnects" from my camera (GH5/G85) when I take a picture with autofocus on my Canon 70-200mm f/2.8 II or my Tamron 24-70mm f/2.8. So far it seems to work fine on my Sigma 18-35mm f/1.8 though (which also seems to be the only lens that people have when I tried searching if anyone else has the same issues).

What I mean by "disconnect" is that it will lose connection momentarily (like if I am twisting the lens off slightly), take the picture, and then "reconnect". Sometimes it'll lose the electronic connection completely (no AF/IS) so I'd have to flip the AF/MF switch on the lens to actually enable the AF/IS (or else turn on/off the camera). Other times it reconnects fine.

The image will shift due to the "disconnecting" (since there isn't any more image stabilization) and will cause the image to be blurry. Has anyone else experience this problem?

I uploaded a video showing the problem here: https://youtu.be/hM_kn9KASzw

Link to post
Share on other sites

If one lens seems to work fine and others don't then perhaps it could be a bad connection between the lens and the adapter?  I'd suggest cleaning the lens contacts on the offending lenses, on the adapter and on the camera as well.  

It's quick and easy and worst case is the problem persists but now your lenses are a bit cleaner and you've ruled out a possible source of the issue :)

Link to post
Share on other sites

Waited for ages for the Viltrox EF-M2 to arrive, and on the first day, my Tamron 17-50mm zoom worked fine. But that was the last time! Cannot change aperture since that first day. Very disappointed and wondering what I'll do with it now. Have been using an old Yashica 50mm prime because that's the only lens I have that fits via a C/Y to EF adapter (unfortunately, all my Nikon old primes have transmission pins that will clash with the Viltrox contacts, so I cannot use them).

I have never used the Metabones so I can't compare it, but I would say the optical quality of the Viltrox is generally very good for the price. But infinity focus needed adjusting. You loosen the small screw (with the mini screwdriver provided) and turn the rear element. It's a bit fiddly - once I misjudged it and the screw came right out. Luckily, the screwdriver is magnetic which helps, but it was a hectic few moments trying to get that small thing back in. You have to use a bit of down force to get the rear element to rotate counter-clockwise while trying to avoid touching the glass. With it moved to the fullest rotation, I'm still not absolutely sure infinity focus is perfect, though.

Link to post
Share on other sites
  • 2 weeks later...

I just had the same thing happen to my Viltrox EF-M2.  I've been using with with the Sigma 18-35 and it just suddenly stopped connecting.  I tried to clean the contacts, update to firmware 3.0, and when I connect it to the GH5 & G85, it will not even up version number anymore.  The aperture dial on it does not work either.  

Link to post
Share on other sites
  • 2 months later...

An update on the Viltrox/Tamron 17-50mm situation. The lens does work again with the adapter now. I don't know what made me try it again, but I found that twisting the lens more firmly round when I mount it seems to achieve a more reliable connection with the adapter's contacts. But, I do not hear a definite lock when I mount the lens, so although the fit is firm, I never feel confident the lens is actually locked on the camera! The vintage Yashica prime locks fine, though.

The issue with infinity focus: again, I thought I had turned the inner element as far as it could go, especially as it's not easy to do this, but having tried it again, there was actually more rotation to be found (it was becoming quite tight to turn, and you are never sure if you should really be turning it this far or not!), but it does now feel like infinity focus has been achieved.

Just wish the lens would lock...

Link to post
Share on other sites
  • 1 year later...

I am using the viltrox ef-m2 with my bmpcc and my Canon 24-70 2.8 L1 and it seems that the back focus is not working. Does anyone knows what do in this combo; I have updated the latest firmware on the adapter but it is not working..... 

Link to post
Share on other sites

i have the ef-m2 on my p4k. My only ai lens is a tokina atx-pro 28-70. the auto focus doesn't work but the aperture control does. its not an issue for me not having auto focus. As i understand  it the nikon mounts don't work through the adapter on the p4k.

i have heard only some older versions of firmware will work with some models you may have to google it, hope that gives you something to work with. you may have to reinstall an older firmware perhaps. Maybe check the contacts see if there is any visible wear or dirt as kye has suggested

Link to post
Share on other sites
  • 4 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...