Jump to content
Sign in to follow this  
Quirky

Power Woes with BMPCC

Recommended Posts

Looks like my BMPCC is dying. Or something is wrong with it.

I've had it for a few months, and it worked just fine until now. With the latest firmware update. I haven't used it for the past three weeks, and it has been stored appropriately in a closet during that time.

 

Today I took it out to prepare it for a shoot, and noticed that it wouldn't power on normally. First I thought the battery had dried out inside it, so I swapped it. Same result. When I press the power button, the screen will flash on like it normally does, but after that the camera goes dark, in less than a full second.

 

Another press of the button either does the same, just a blip on the screen, then nothing, or it doesn't do anything. After recharging and trying out four different batteries and even with the power chord plugged in the camera, with or without a battery inside, the result is always the same. The camera powers on for less than a second, then becomes a brick.

 

The camera does still have a warranty, obviously, and I know I'll probably have to send it in for a warranty repair, but I was just wondering if anyone has had a similar problem, and if anyone might know if there's anything I could try before sending it in.

 

After all, sending it in for a warranty repair will probably take quite a while, and I'd like to avoid the hassle, if this happens to be some known issue and fixable by the user.

Share this post


Link to post
Share on other sites
EOSHD Pro Color for Sony cameras EOSHD Pro LOG for Sony CamerasEOSHD C-LOG and Film Profiles for All Canon DSLRs

Thanks for the reply. I think you're on to something with the firmware thing, and I think I kind of figured it out myself, too. At least I hope so. 

 

I did some research last night. Apparently the latest firmware has changed the sensitivity of the power button for some unknown reason, and it no longer works like it used to. Before the latest update you were to give the power button a good push before the camera powered up. After the update only a short push is needed, and if you push it longer, like you used to, the camera will power off right away, resulting in a quick flash of the screen as described in the OP.

At least I hope that's simply the case.

 

Unfortunately I had already sent the camera in for a warranty repair before I discovered this, so I can't confirm it right away. That's why I haven't commented about it in this thread yet. I'll come back with a confirmation as soon as I get one. I really hope it's something as simple as that, so that I'll get my camera back as soon as possible. 

 

Meanwhile, another tip I found yesterday was that if you face the same kind of problem, try pushing the power button for 10 seconds, and then release it. After that, try powering the camera on again normally, with just one short push. That ought to do it, I'm told.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By Lenscamera
      Hi,
      I have a brand new unopened Blackmagic pocket cinema camera 4k that I bought from B&H. Still in it's wrapped plastic seal from B&H so obviously it includes everything that comes with it. I am thinking/considering going a different route with my camera gear and looking to gauge interest if anyone is looking for one. 
      Let me know if you're interested. 
    • By Sandeepthefifth
      Hey all, I'm looking to shoot a narrative short film with controlled lighting early next year and am thinking about shooting it on my original BMPCC...
      I know, I know. No 4K, terrible low-light, and horrible battery life. But if 1080p was fine, controlled lighting throughout, and an external battery solution, is it better for me to use the original and cancel my 4K pre-order? I could use the money saved to pay for an additional cine prime/actually pay actors a decent wage...
      What would be the advantages in this case of using the 4K over the original?
    • By Bradley Bjornstad
      Hello there. For sale is my well cared for and maintained Blackmagic URSA Mini EF 4K + Gold mount + Battery + 256 GB CFast 2 + Top handle & more! This package is ready to shoot!
      I handle my gear with great care. This is an amazing camera that makes incredible images. I am downsizing all my gear and sadly decided to sell this for other expenses.
      $2,575.00 + $55.00 shipping. 
      This listing includes:
      • The camera - Ursa Mini 4K EF Mount (in product details it says Ursa 4K but it is in fact the Ursa Mini 4K EF to clarify)!
      • Fitted Hard Case for it.
      • Attached Gold Mount and 95wH Comer Gold Mount battery (only charged 3 times basically new). Works great with nice charge.
      • Delkin Cinema 256 GB CFast 2.0 card.
      • A Camvate top handle.
      • A d-tap travel charger for the battery and other cables included.
      DOES NOT include DaVinci Resolve dongle.
      PayPal ONLY, and no returns.

      Any questions just write here or email me at: [email protected]
      Thank you so much for looking at my gear.
      Best wishes,
      Bradley











    • By DIGICHombre
      https://www.ebay.com/itm/Cine-NIKKOR-25mm-F-1-8-Nippon-Kogaku-C-Mount-Wide-Angle-lens-ADAPTER-Included/112964898960
      Great condition lens + micro four thirds adapter. Used it on my blackmagic micro cinema camera. Lens is made for 16mm sensor. 
      $315.00 USD. 
       
×
×
  • Create New...