Jump to content

Editing 4K 100mbps Clips on a Macbook


Linakesh
 Share

Recommended Posts

Currently using a mid-2015 MBP 2.2 i7 w/ 16gb of ram.  As soon as I add the videos to iMovie (moving to FCPX this week) and layer them with green screen or picture in picture/etc. the computer slows and sounds like a jet engine taking off.  Not sure if creating proxies or upgrading new a 13" MBP 2020 model would be helpful. Also edit internally vs. external thoughts?

I will be creating mostly 5-15m videos for educational purposes on a weekly basis.

 

Thanks!

Link to comment
Share on other sites

On 8/6/2021 at 5:52 AM, Linakesh said:

Currently using a mid-2015 MBP 2.2 i7 w/ 16gb of ram.  As soon as I add the videos to iMovie (moving to FCPX this week) and layer them with green screen or picture in picture/etc. the computer slows and sounds like a jet engine taking off.  Not sure if creating proxies or upgrading new a 13" MBP 2020 model would be helpful. Also edit internally vs. external thoughts https://19216801.onl/ ?

I will be creating mostly 5-15m videos for educational purposes on a weekly basis.

 

Thanks!

I got this,..

Link to comment
Share on other sites

I m currently editing 4k 160mbit on a base 8gb/256g m1 MBA with external 2tb ssd, pretty smooth most of the time except some lag when scrubbing timeline occasionally on longer videos.

And 0 sound as there is no fan.

20210806_230707.jpg

Link to comment
Share on other sites

On 8/8/2021 at 3:02 PM, ntblowz said:

I m currently editing 4k 160mbit on a base 8gb/256g m1 MBA with external 2tb ssd, pretty smooth most of the time except some lag when scrubbing timeline occasionally on longer videos.

And 0 sound as there is no fan.

I can beat that! I edit 8K 12bit RAW videos on my 8GB MacBook AIR M1:

AIR 8K.jpg

Link to comment
Share on other sites

On 8/8/2021 at 3:02 PM, ntblowz said:

I m currently editing 4k 160mbit on a base 8gb/256g m1 MBA with external 2tb ssd, pretty smooth most of the time except some lag when scrubbing timeline occasionally on longer videos.

And 0 sound as there is no fan.

20210806_230707.jpg

H264?

Link to comment
Share on other sites

  • 2 weeks later...
  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...