Jump to content
Sign in to follow this  
DPC

Metabones Canon EF Speedbooster + Tokina 11-16: no infinity focus

Recommended Posts

I have just bought a Metabones Canon EF - MFT Speedbooster and A Tokina 11-16mm I was hoping to use it with on my GH4.

The Speedbooster works fine with Canon lenses. Images are sharp and I can focus to infinity.

When mounted directly on a Canon body, the Tokina works perfectly in both auto and manual focus modes. Images are sharp at infinity.

Here's my problem: when I mount the Tokina lens on my GH4 via the Speedbooster, I can't focus to infinity. Worse, I can't focus further than about 4 feet (when the lens shows infinity). This makes the combination totally useless. Does anyone have an idea what might be going wrong here? I can't return either the lens or the adapter because separately they work fine. Together (which is exactly how I wanted to use them) it's a disaster. 

The strange thing is that I don't remember having this problem when I got two items three weeks ago. Neither has been dropped, knocked or otherwise mistreated.

All help gratefully received!

Share this post


Link to post
Share on other sites
EOSHD Pro Color for Sony cameras EOSHD Pro LOG for Sony CamerasEOSHD C-LOG and Film Profiles for All Canon DSLRs

In case someone else has the same problem, this is what happened: the Speedbooster was delivered with the screw that holds the rear lens element in place completely loose. 

At some point the element was cleaned with a cloth and moved, thus making infinity focus impossible. I have readjusted and locked the screw down and all seems to be well.

I'm sure you will understand that I'm not at all happy...

 

Share this post


Link to post
Share on other sites

In case someone else has the same problem, this is what happened: the Speedbooster was delivered with the screw that holds the rear lens element in place completely loose. 

At some point the element was cleaned with a cloth and moved, thus making infinity focus impossible. I have readjusted and locked the screw down and all seems to be well.

I'm sure you will understand that I'm not at all happy...

 

Hey DPC! 

From what i've read extensively online, even if the screw wasn't loose many people are still having the same issue with their brandnew Metabones speedbooster coupled with a GH4 and the newer baby brother G7. I ordered the new Speedbooster XL 0.64x for Canon and i'm thinking about returning it given the issue.

I don't believe cleaning and moving the element should be a fix for this issue and you may find your optics with the speedbooster are slightly out. The issue surely has to be an incompatibility with Panasonic cameras, not the lens or the speedbooster itself. 

Would be great to know how your getting along now and if you are still having the same problem? Have you heard any new info about this issue? 

Cheers

Joel

Share this post


Link to post
Share on other sites

Sorry, just seen this.

I adjusted my Speedbooster myself initially and then sent it back to Metabones for re-calibration.

I'm not sure there was much difference between my repair and the subsequent factory one.

Since then I have had no problem at all and use the thing all the time.

 

Share this post


Link to post
Share on other sites

Sorry, just seen this.

I adjusted my Speedbooster myself initially and then sent it back to Metabones for re-calibration.

I'm not sure there was much difference between my repair and the subsequent factory one.

Since then I have had no problem at all and use the thing all the time.

 

My Speed Booster XL was also delivered with a loose screw. Extremely disappointing for an instrument costing $750 USD. I had to take it to a local camera repair shop, it took them 1/2 an hour to set things right. It's worked fine since.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...