Jump to content
BTM_Pix

TechArt Pro Sony E To Nikon Z Adapter

Recommended Posts

On 7/10/2019 at 2:37 AM, webrunner5 said:

Oh imagine my surprise a 600 dollar 50mm Nikon lens is better than a 250 dollar Sony 50mm lens

He wasn't comparing it to a cheap Sony lens, but a very expensive E Mount lens:
 

On 7/10/2019 at 2:14 AM, Castorp said:

 

The Nikkor 50/1.8S is nothing short of a game changer. It's Zeiss Otus level optics for 600$!

 

Share this post


Link to post
Share on other sites
EOSHD Pro Color for Sony cameras EOSHD Pro LOG for Sony CamerasEOSHD C-LOG and Film Profiles for All Canon DSLRs

@Andrew: Any update or communication from the TechArt folk following our last conversation on whether the TZE or TA-GA3 will ever work with Contax G on the NZ and possible s/w updates to support this.

I had a very brief one liner reply from Kevin(TAP Sales) saying that “Currently it does not work super well with TAGA3.”

No reply or follow up clarification to the mails/queries I sent but I would really hope this was on their radar too as both adapters are TA products.

Share this post


Link to post
Share on other sites

I guess the Leica M AF adapter will not work with the TZE for political reasons. Because Techart would never have puplished the function on their webside if it would not have been working and bcause they have now withdrawn this statement.  Maybe it will work with the older firmware versions. This is probably the same reason why the development of Steelsring Nikon2Fuji is pending for a long time although videos have proven the function already!

Share this post


Link to post
Share on other sites
On 7/18/2019 at 11:34 PM, Andrew Reid said:

Nada, nothing. They don't seem to reply to emails. I suppose we'll have to keep an eye on their website for firmware update news.

The Version 2.0 update is now available for the TZE-01.

I updated to ver 2.0 in the hopes of compatibility with TA-GA3 and CG lenses. Sadly no change, in fact on version 1.0(TZE) there would be an initial buzzing sound as AF motor engaged initially when camera was switched on, but now nothing happens on version 2.0.Wonder whether this is even on their roadmap...

Share this post


Link to post
Share on other sites

Is there any new information on the Leica M to Sony E adapter working on the Sony E to Nikon Z adapter? I wonder if you actually went back to a previous firmware update (say ver 4.0) if it would work? Most of the newer FW updates were for compatibility with the newer Sony A7 or A9 bodies. Would love to use my M lenses wit AF on the Z7.

Any input on this?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...