Jump to content

Please please please help, need help so bad.


craigbuckley

Recommended Posts

Ok so i filmed a show tonight that is very important to me, and when I got home I watched the footage on my laptop and it was fine. I uploaded the majority of the files but one file was 45 minutes long so I waited to upload that file after I charged my battery. I closed the program and ejected my camera safely from my mac and charged my battery. When I turned the camera back on my footage was gone! I didn't get to upload this file (45 mins) and it was the most important file that I needed so badly, and now its gone and I'm freaking out. Is there anything I can do? When I look on my camera it says no valid picture to display, but I never deleted the footage off my camera... Is there anything I can do? I'm dying over here... its for my final project is there anything i can do


(I'm using final cut pro x, gh2, sandisk etreme pro 32gb 95mpbs)
Link to post
Share on other sites
Take out your memory card and pop it into your card reader. If you are using OSX Mountain Lion then you should be able to look at GH2 videos from the finder. Double click on the "PRIVATE" folder and it should pop QuicktimeX and then an "Open file" window where you should see all your videos storied on the card (those that are stored in .mov format (MJPG) are in with the photos.

If you are using an older version of OSX, then you will see a folder called "PRIVAT". go into that folder by right clicking on it and choosing,"Show package contents". then do the same for the folder called "AVCHD" and then into "BDMV" and you should see a folder called "Stream". Inside are all the videos with a .MTS extension.

If there is nothing in there, then they really are gone. I'm not sure how this happened since I don't know what process you used to get the movies onto your computer. If you are using Log and capture, you should be able to navigate to the card while it's plugged into your computer and grab the files that way.
Link to post
Share on other sites
Those MTS files are your footage. FCPX probably added some metadata to the files making them unreadable by the GH2.

You'd better convert them to an edit friendly format and back up your footage before you freakout again.

If footage is really important and money is involved, back up first! At least this is my experience working with different production company's.
Link to post
Share on other sites
You didn't really record an uninterrupted 45' clip with a high bitrate hack? You did read all the warnings on thoroughly testing hacks before using them in real life? That - hacked or not -, after the recording of a longer than 5 minute clip, you should record a one second clip to force the camera to store the previous (which can take a few seconds)?

[b]> if you know you must record big chunks, unhack![/b]

[quote name='craigbuckley' timestamp='1351308578' post='20418']When I look on my camera it says no valid picture to display, but I never deleted the footage off my camera...[/quote]

This sometimes happens with hacks. I can't explain it, if it was on an unhacked GH2, one were entitled to call it a bug. Most times it helps to put the camera off and then on again, sometimes not, depends. But stay calm. I wasn't able to play back a lot of clips in the camera, but they were on the card. Unless you deleted something intentionally, probably nothing is gone. Only, if it wasn't stored in the first place.

[b]> never use your camera as card reader![/b]
[b]> use the card reader to make a copy of the card in a new folder on your hard drive.[/b]

If you plan to work with the native AVCHD, this folder, named i.e. [i]show oct 25[/i], should better be on a partition or a second drive (not just USB-connected). There is a simple reason for this: FCP X allows you to skim through all your footage diagonally. Since this is a file-based workflow, the computer needs to have quick access to all of the files it must display. At once. Poor USB 2.0 is the bottleneck here. It will cause FCP X to crash.
Link to post
Share on other sites
ok thank you for your help guys. Sorry for freaking out this just is the worst, don't know what I am going to do.. but I will try converting the .mts files and see what happens...

I do have another question though, I did buy a brand new 32 gb san disk extreme pro memory card yesterday and that is what I used to record the footage last night. I realized that I didn't put the hack on this memory card, so was I not even using the hack at all? Does the hack depend on the memory card? because I originally hacked my camera with another memory card in it.. Man this scares me to use the hack in the future..

(EDIT): I converted the .mTS files to a quicktime format but they still wont play.. Does anyone suggests using an sd recovery software to attempt to get this file back?
Link to post
Share on other sites
I know im not being clear enough and its a very confusing situation... let me start over please...

So i filmed a show last night. I recorded the whole set (45 minutes) in one shot, and then I had some other bullshit shots that were extra... When I got home I plugged in my camera through usb (i know- dumb) and imported the shorter files into final cut and left the long shot on my camera because my battery was low and I wanted to charge it so my camera wouldn't die while transfering files... I unplugged safely and charged my battery, then tried to import again and nothing. I unplugged my camera and looked on my camera but it says no valid pictures to display... I put my sd card in the mac directly and still nothing. No .mov files like usual but I did find about 10-15 clips of .mts files... I converted these files to a few different formats with a few different converters and it ended up only being the audio and a still image, no video.. I don't know what to do but I could use two things out you guys, and I really appreciate your help.

1. Is there anyway I can recover these files? I know its confusing but I am going to try the geek squad.

2. What should I do in the future to import files into final cut?... (Final cut pro x freezes a lot so maybe importing through that isnt safe?)
Link to post
Share on other sites
Maybe the very long recording wasn't saved in-camera. Then the video data were stored, but not completed and not indexed. This way they are orphaned and can't be found.

[quote name='craigbuckley' timestamp='1351373023' post='20450']
1. Is there anyway I can recover these files? I know its confusing but I am going to try the geek squad.[/quote]

I hope for you somebody knows.

[quote name='craigbuckley' timestamp='1351373023' post='20450']2. What should I do in the future to import files into final cut?... (Final cut pro x freezes a lot so maybe importing through that isnt safe?)[/quote]

• Importing files into any NLE is the safest thing on earth, if you make the backup [i]first[/i] (for which there is another reason, as described above).

• FCP X is not supposed to freeze at all.[i] [/i]Given your mac meets the hardware requirements, you have updated FCP to current version and run either Lion or Mountain Lion. And given you don't try to play a 45' AVCHD clip with high bitrate from your camera via USB.

This has not to do with safety, because you work with a copy of your card. The only difference can be to work with 'optimized media' instead of mts originals, the default option of FCP X with AVCHD and done automatically when you hit import. Optimized means easier to edit (ProRes).

Maybe you accidentally did not record AVCHD at all, but motion jpeg. Then your files will be movs in the DCIM folder. These files will not be converted.
Link to post
Share on other sites
I am curious. Did you playback the 45 min clip, in-camera (or atleast a portion of it), before transferring it? I am assuming, that:

1. Either the clip was never saved, in the first place (or a very small portion of it was recorded), before it stopped, on its on.

2. While transcoding, through the various software you used, you either changed it into different programs, ruining the final video, somehow, or into a form, which your video player, does not recognise.

hmmm ...
Link to post
Share on other sites
ok I couldnt find "optimized media" under final cut events, the thing is I never saved it or imported it to final cut. I started to import that file but my camera got low battery so I cancelled, ejected my camera and charged the battery. Next time i turned my camera on all the files were gone... It said no valid pictures to display... I did playback the footage on my camera though and watched it, and also on my computer but never saved it or imported it...

My only hope is the .mts files that I found that have the audio from the show , but it won't play the video. I have tried so many different converters but nothing is working. Has anyone ever experienced this?
Link to post
Share on other sites
Okay so, you found the .mts files? Good! These are the actual videos! those are raw mpeg stream files. You don't need any kind of recovery software or service because you have already found the files you needed. I have a few questions and I need you to answer each question:

1.) What MacBook do you have? It's possible your hardware is not fast enough to play those clips.

2.) Are running Mountain Loin?

3.) What format did you use to record the videos on your camera. This is really important!

4.) Were you able to find the specific .mts file of 45 min video?

5.) Can you tell me what software you used to convert the .mts files and what format did you try and convert them to?

So, it sounds like your issue is that you have the .mts files but converting them to another format doesn't seem to give you files that are usable. It's possible that in the conversion process you converted it to a format that was to stressful for your computer. I've come across files downloaded from the internet now and then that can't be played reliably from quicktime for VLC. Usually I just need to convert them to ProRes or simply import them into my editing software.

If you do know which .MTS file is the 45 min clip, do me a favor and download the free (lite) version of 5DtoRGB: [url="http://rarevision.com/5dtorgb/"]http://rarevision.com/5dtorgb/[/url]
This will allow you to convert the .MTS file to a ProRes quicktime file. Then, try importing that into FinalCutX and it should be fine. The thing you need to remember is that if you have the .MTS files, you have not lost anything.
Link to post
Share on other sites
Galen B,

Your the friggin man! That programmed seemed to work!! It seems like it split that long 45 minute up into different files, which is ok! This is awesome. Thank you so much!

I am going to go run around for a while!



Ok that was great. Your the best. Thanks to you all on this website...

So in the future, to prevent this from happening... I should format my SD card and import through final cut? or is there a better way?
Link to post
Share on other sites
[quote]Your the friggin man! That programmed seemed to work!![/quote]
Of course it did. I'm the friggin man, what else did you expect?

[quote]Copy to my hard drive? When I open final cut there's an option to import from camera an usually do this but now I'm skeptical. Is there a better way?[/quote]
You can definitely do it that way. However, what I think most people do is to copy the contests of the card onto their hard drive in order to create a backup and then use that with log and capture instead of their cameras:

Make a folder on your hard drive called "Archive" or "Footage" or something. Insert card in card reader, find the "Privet" folder, copy it to that folder on your hard drive, rename to whatever you want (usually the name of the event or scene/shot). Now, when you log and capture, choose "Open Archive" button in the lower left part of the window. Point it to your Footage folder. Now you will have a little link in the list on the left. Click on this and you should see your footage. Now you will never loose a shot because they will all be on your hard drive.
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...