Jump to content
Andrew Reid

Metabones firmware update for Canon EF adapter improves compatibility with Sony A7S

Recommended Posts

EOSHD Pro Color for Sony cameras EOSHD Pro LOG for Sony CamerasEOSHD C-LOG and Film Profiles for All Canon DSLRs

hey guys!

 

I need some help here. I have an A7s and a Metabones Ef to E mount speedbooster. How do I do the actual update? The port in the side of the speedbooster is some weird port I've never seen and isnt mirco USB like the site states. I bought the Metabones 3 weeks ago from b and h. 

Share this post


Link to post
Share on other sites

The Micro USB port is directly adjacent to the spring-mounted lens release lever -- under the oblong black plastic cap.

 

I seem to recall older versions of this product possibly having a proprietary port (not USB) that was unusable by the customer.

 

Be sure to look at the back of the plastic case your adapter came in to determine exactly which version was sold to you.

 

In the upper right corner of the foil label it should say "Mark IV"

Share this post


Link to post
Share on other sites

Hi just got myself a Metabones smart adapter iv with updated firmware 0.4, and it intermittently crashes the a7s when I use the Canon 50mm f1.2L. Also the Canon 300mm f4L IS USM does not even work correctly, and perceptually locked up the a7s when the silent shutter is used. I thought the 0.4 update was meant to fix this issue.

 

The 300mm f4L IS USM does not even allow proper aperture control when used on the Sony Nex 5r.

 

I also own a Metabones Speedbooster original version, and all the same lenses that had issues with smart adapter iv, have no issues what so ever and works perfectly.

 

It seems the newer software or processor in the smart adapter iv is not as compatible as the older metabones speedbooster.

 

Please Metabones, maybe you could make multiple firmwares, one for better compatibility with video cameras like FS7, and another for digital emount cameras like the NEX 5r or a7s.

Share this post


Link to post
Share on other sites

The metabones mkIV I've bought around 2 weeks ago from CVP apparently already had the update installed. However I'm  experiencing a number of issues, mainly with the 17-55 (image remains black when camera turned on, unmounting & remounting lens required). Anyone else experiencing such issues?

​the pins on the metabones adaptors are too long and end up shorting.  I've had no end of problems with lenses that are fine on canon cameras yet cause bugs with the a7s and a7r.

the only solution is to tape over the connectors.  

Share this post


Link to post
Share on other sites

​the pins on the metabones adaptors are too long and end up shorting.  I've had no end of problems with lenses that are fine on canon cameras yet cause bugs with the a7s and a7r.

the only solution is to tape over the connectors.  

​interesting theory. I think the "shorting" issue may be quite valid. I found the most issues when changing between green and advanced modes on the adapter. To do so requires the adapter to be dismounted either at the lens, or the camera side of the adapter, then while depressing the button on the adapter, mount it back, all while leaving the camera set to it's on position. After the remount, frequently with the a7s the camera will malfunction, display black, or no f stop values, etc. The only way to resolve is to do a battery pull, and then the adapter seems to work correctly again.

 

What is strange though, is my other Metabones Speedbooster adapter has no such issues on the a7s, and I can mount and dismount the adapter without any issues.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...