Jump to content

Easier 5D Mark III raw guide in 4 steps

Andrew Reid

Recommended Posts

To enable smooth "allowed drop frame",

Can you upgrade the code, so that it will do the raw recording using

[  take 1 / drop 1] --- take 1 of 2

Frame 1  Take

Frame 2  Drop

Frame 3  Take

Frame 4  Drop

Frame 5  Take

Frame 6  Drop ... etc


[  take 1 / drop 2] --- take 1 of 3

Frame 1  Take

Frame 2  Drop

Frame 3  Drop

Frame 4  Take

Frame 5  Drop

Frame 6  Drop

Frame 7 Take

Frame 8 Drop

Frame 9 Drop

... etc


And also Take 1 Drop3 (1 of each 4)


This is to enable smooth drop frame and catch up the card writing speed,


can you make this possible for new updates? Thanks

Link to post
Share on other sites
  • Replies 75
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

UPDATE: Full book now available - The EOSHD 5D Mark III Raw Shooter's Guide   Here's a quick and easy way to get raw recording setup on your 5D Mark III thanks to the recent Magic Lantern developmen

Awesome tutorial. I'm up and running and making raw video on my 5dmkiii! Thank you for putting together this one-stop method for getting up fast.    The only missing link for  me, a Mac user, is con

Hey! That did it. Thank you. Off to play with my new Red...errr, 5dmkiii. 

Thank you for all your time and research! This guide and all the tests are so awesome.

I'm trying to test this out myself and running into a speed bump.


When I enter the ML menu I do not see a 'raw video' button in the 'movie' menu.
Just downloaded the '
Magic Lantern June 3rd(5dee6fc)' version.


I'm on a v.1.1.3 5DmkIII w/ a 24-70 and ML on a Lexar 32gb 1000x in manual M mode in switched over to movie mode.
I also have the canon side set to 1080 24p and tried with it set to all-i and ipb and still don't see the 'raw video' option.

The menu options i get in the ML movie tab are:

-Load H264.ini

-REC indicator

-Gradual Expo.

-FPS override

-HDR video


-Image Finetuning

-Movie Tweaks 


I don't see 'raw video' within any of these options either.

Am I doing something wrong? Or is this just different in this latest build somehow?

This is my first time with ML.



Link to post
Share on other sites

When I enter the ML menu I do not see a 'raw video' button in the 'movie' menu.


You first need to "Load Modules" in the last tab.  (you can also check "Always Load Modules on startup"

(or something to that effect, don't remember exact wording - camera not with me) 

After you Load Modules, the RAW Video option will be there

Link to post
Share on other sites

May I know how to contact Andrew to update my suggestion above (skip/drop frames consistently in RAW module )?
It should be very easy coding to update this, please? [Drop/Skip 1 of 2, or Drop/Skip 2 of 3 (take 1 of 3)  , consistently?, instead of fps overriding]


Link to post
Share on other sites

May I know how to contact Andrew to update my suggestion above (skip/drop frames consistently in RAW module )?
It should be very easy coding to update this, please? [Drop/Skip 1 of 2, or Drop/Skip 2 of 3 (take 1 of 3)  , consistently?, instead of fps overriding]


Andrew is not the developer.  You should post this on the Magic Lantern forums and address it to the developers there.




They check it everyday and can help you with this.

Link to post
Share on other sites

I just installed ML on my 5D Mark III and everything works great.


Is there any settings you recommend when shooting video?


I know its RAW, but is it still possible to shoot with any of the picture styles? Also, they way it looks in the viewfinder, is not how the output looks. The output is a lot darker, and way more contrast.

Picture styles work on JPEGs and H.264 video only.  RAW video is exactly like RAW photo stills.  You can change anything - WB, contrast, exposure, saturation.  If you feel that it's too dark or too contrasty, then change it to how you want it.  Of course you still need to expose correctly, but there's more latitude for adjustments. 


If you feel that the Liveview is different or too dark, you should check your Liveview brightness settings.  Perhaps it's too low, make the LCD brighter.  I think stock is too dark, maybe push it up 1 or 2 levels.  Don't forget to NOT cover the little tab on the back of the camera, under the LCD.  It's this little circular "button" but it doesn't do anything.  Well actually, strangely it measures the ambient light and automatically adjusts the LCD.  Don't cover it and your LCD should be fine.


I hope this helps!

Link to post
Share on other sites
  • 2 weeks later...
  • 2 weeks later...

I've purchased the book, followed the instructions and have not been successful. I'm sure I'm doing something wrong, but after two days of trying, I can't figure it out.


One item that would be very helpful is a screenshot of the SD card directory. This would help me know if I'm missing a file and so forth.


When trying to load the SD card on the md3, yesterday I did not receive a Enable Boot message. Today, I just get "Update software cannot be found..." 


I have tried to different SD cards. Ex-fat formatted. Movie mode. M mode. 


The instructions on this page http://www.eoshd.com/comments/topic/2729-easier-5d-mark-iii-raw-guide-in-4-steps/

seem to be different than those in the book. I have not been successful with either. 


Which directions should I follow. The book or the article. 


I have a Mac OS 10.6.8. I used MacBoot.class


I'm using Magic Lantern June 27th(3ecd254).zip


Any guidance would be greatly appreciated.





Link to post
Share on other sites
  • 2 weeks later...

When i first commented, i just shut the camera off after getting the "EnableBootDisk :)" and then once i saw your reply i simply turned it back on and everything was up and running

Andrew I got this far in the install but when I powered down and powered back on I still wasn't getting the menus to come up when I hit the trash can. I just had an empty frame with my grid and focus box.


Any ideas?

Link to post
Share on other sites

I've gone through instructions step by step multiple times on 2 different 5D mk iii's with different sd and cf cards and am getting the same result which is "enable boot disk :)"


To which I power off the cam and power back up, hit trash can and nothing.


Throughout the process I have noticed that firmware "1.1.3-ml-v2.3.next" does not stick. I will get to step one of the instructions on the EOS guide but when I come back to step 2 I see the firmware reverts back to the canon 1.1.3


Any suggestions on what I'm doing wrong?

Link to post
Share on other sites

Having issues with the installation.


I bought the The EOSHD 5D Mark III Raw Shooter’s Guide and I am following the instructions..


When I complete step 5 on page 27,  I get the "BootDiskEnable :-)" message.   But when I hit the trashcan button after doing that nothing happens at all.


I took out the SD card after that to view the contents and there is now a "ROM" file on the card as well..




When I attempt to make a bootable SD Card,  ML does not boot to the Card,  firmware goes back to its original v1.1.3 and when I try to run the ML install,  it says no update file exists.


Can anyone tell me what I am doing wrong?   I am following the instructions to the letter,  and this process is not working for me





Link to post
Share on other sites



I am having this exact same issue.  FW is not sticking and the Trashcan button does nothing after running the update.


Did you ever find out what the fix was for this?




Here is what I am doing:


I am trying to install ML with the RAW Video Module.

- navigated to this link - http://www.magiclantern.fm/forum/index.php?topic=6362.msg49471#msg49471

- then scrolled down to the 5D MK III section under Lourenco's builds

Updated build for 5D3 as of July 13th.

I downloaded the Zip files from the Google drive and moved the proper files and folders to the card.

SD Card Contents:

ML (Folder)

- I look and the firmware is : v1.1.3 which is what it is supposed to be.

- I update the Firmware and at the end it says "EnableBootDrive" with a smiley face, which is expected.

- I then press the Trashcan button and absolutely nothing happens.

current version = 1.1.3-ml-v2.3 NEX ...so the update was successful

Not sure why the trashcan button is not opening up the ML screen.

Please help...does anyone have any experience with this issue?


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...