Jump to content
Romanesco

Samsung NX1 EVF Problem - Black EVF Screen

Recommended Posts

Hi there,

I just received my brand new Samsung NX1 and after updating it to the latest firmware (1.40) and taking a few photos, the EVF stopped working. As soon as I look into it or press the EVF button it blinks once in white then turns black.

Has anyone encountered this issue before? If yes, how did you fix it?

PS I did try a reset and a firmware re-install - it didn't help.

Share this post


Link to post
Share on other sites
EOSHD Pro Color for Sony cameras EOSHD Pro LOG for Sony CamerasEOSHD C-LOG and Film Profiles for All Canon DSLRs
10 hours ago, Romanesco said:

Hi there,

I just received my brand new Samsung NX1 and after updating it to the latest firmware (1.40) and taking a few photos, the EVF stopped working. As soon as I look into it or press the EVF button it blinks once in white then turns black.

Has anyone encountered this issue before? If yes, how did you fix it?

PS I did try a reset and a firmware re-install - it didn't help.

Here is a video of the problem: 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...