Jump to content

Extremely glitchy FCPX glitch after importing Premiere project and relinking files


manueldomes
 Share

Recommended Posts

So I had to edit a project in Premiere Pro CC, which I then exported as FCP XML, converted with SendToX, and imported in FCPX without any problem. I was aware that I would have to relink all media files from the project, so I plugged in the drive containing them, selected the folder through relink files dialogue, and it matched all missing files. However, despite finding all matches, it won't relink the files (with the exception of two or three clips, weirdly). I then consolidated all media files to the new library location on another hard drive, and FCPX started copying them all over. When I click "reveal in finder", it actually locates the media files, which are clearly there and correct (on the flash drive prior to consolidation and on the hard drive after consolidation). I'm at a bit at a loss, anyone have an idea what else I could try? Thanks!

Screen Shot 2017-11-14 at 22.24.05.png

Screen Shot 2017-11-15 at 09.10.18.png

Link to comment
Share on other sites

Deleted the event, imported again through SendToX with flash drive inserted, files were found during import but still missing, went to relink files dialogue and they were supposed to be in all kinds of weird locations, but it did manage to import all missing files from the flash drive this time (though I didn't do anything differently from before). So my problem seems solved, but this doesn't seem overly reliable...

Link to comment
Share on other sites

A couple of glitches I've had with FCPX....1: as I'm importing one selected file into the NLE, it suddenly imports everything on the card like a batch capture...I used to think it was the GH2 hack, but it does it with all my other cameras too.

2: I moved a few libraries to an external drive and got the same missing file red triangle of death as you...FCPX technical support discovered that what was missing was the grading done in post, after I moved the projects...they were  small things of little importance, except personally for me. I now only open and work in FCP with all footage captured straight into an external drive and no longer see the problem of "missing files" occurring. The unauthorized "batch capture" still continues, though not consistently, and I still have no idea what triggers it?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...