Jump to content
Sign in to follow this  
valid

Foggy lens element rescue

Recommended Posts

Hey guys,

I salvaged an old anamorphic projector lens, and there's an issue with the rear element (specifically, its outer surface).

It's foggy (almost like ground glass) - but it also has some tiny splotches which are clear. Based on the shape of the splotches, I figured it was somehow fungus related, so I gave the lens element a short vinegar bath, and then also some stronger fungicide, but it didn't change anything. I also swabbed the surface with acetone (I figured I can at least take off some of the coating) but again, nothing happened. This thing seems to be bulletproof... The other side of the element, as well as its cementing, seem to be fine.

I attached some pictures. Any ideas how to restore this? I am happy to strip away the coating or any other drastic measures, as at the moment this element is unusable. :confused:

 

CLEAR SIDE:

2h5k5g5.jpg

b4yfpz.jpg

--

FOGGY SIDE:

27xntl5.jpg

hrbq1e.jpg

Share this post


Link to post
Share on other sites
EOSHD Pro Color for Sony cameras EOSHD Pro LOG for Sony CamerasEOSHD C-LOG and Film Profiles for All Canon DSLRs

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...