Jump to content

Voigtlander Ultron 40mm f/2 SL II EF focus issue


Henchman
 Share

Recommended Posts

I have 2 Voigtlander Ultron 40mm f/2 SL II Lenses. One is EF one is Nikon.
For some reason the EF will not focus with my BMPCC 4k.
I've tried both a speedbooster and passive adapter.

What could the problem be? 

Link to comment
Share on other sites

  • Super Members
10 hours ago, Henchman said:

I have 2 Voigtlander Ultron 40mm f/2 SL II Lenses. One is EF one is Nikon.
For some reason the EF will not focus with my BMPCC 4k.
I've tried both a speedbooster and passive adapter.

What could the problem be? 

Do you have a Nikon to EF adapter to see if that then causes the same issue with the Nikon version ?

Link to comment
Share on other sites

On 5/7/2021 at 4:11 AM, BTM_Pix said:

Do you have a Nikon to EF adapter to see if that then causes the same issue with the Nikon version ?

I actually had a friend try it on his canon.

Same issue 

Link to comment
Share on other sites

On 5/7/2021 at 4:11 AM, BTM_Pix said:

 

 

Fixed it.
It was the helicoid not being assembled correctly.
I had to disassemble the entire lens and Re-insert the helicoid at a different start position. Took a couple of frustrating hours of trial and error. But now it's tack sharp.

And I saved myself $250

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...